It's all about the answers!

Ask a question

Tomcat server not starting


Richard Clayton (1112) | asked Jun 20 '12, 3:35 a.m.
Hi,

I've recently installed jazz team server with the aim of using RTC.  When I select to start the server, a dos window opens for a few seconds and then disappears.  Nothing else happens.  I think that Windows is somehow stopping the tomcat server from running or connecting to any of the ports. 

Has anyone seen this before or have any ideas about resolving this? 

Thanks in advance

6 answers



permanent link
Scott Rich (57136) | answered Jun 21 '12, 10:18 a.m.
JAZZ DEVELOPER
The 4.0 server.startup script asks for 4G of memory at JVM startup.  If this isn't available, the JVM might just be failing to start.  I would still expect to see something in the logs, though.  To try a workaround, edit the -Xms (or even -Xmx) settings in server.startup, although the result will be a server with limited capacity.

Scott

Comments
Richard Clayton commented Jun 21 '12, 11:36 a.m. | edited Mar 06 '13, 10:17 a.m.

Ralph, tried your suggestions with no success and I couldn't see anything in the windows logs

Scott,  changed the -xmx setting in the server.startup to 2gb with no effect. 


Jin Zhou commented Mar 06 '13, 7:49 p.m.

Hi, Scott

Your above suggestion works for me.
Thank you for the idea.

Regards


Stanislav Zubarev commented Mar 20 '13, 2:30 a.m.

Works for me also! Thanx a lot!


permanent link
Derrick Babb (1611) | answered Jul 14 '12, 2:31 a.m.
Memory. Running Windows 2008 R2 VM on ESXi, setup with 2GB of memory and same symptoms. Upted the memory to 8GB and all is right in the world again. Thank you for this post. Good work whomever debugged catalina.bat to figure this out.

permanent link
Ralph Schoon (61.1k33643) | answered Jun 20 '12, 4:30 a.m.
FORUM ADMINISTRATOR / FORUM MODERATOR / JAZZ DEVELOPER
Hi Richard,

can you open a console as Administrator and CD to the JazzTeamServer/server folder and run the server.startup.bat from there? Does it work then?  Is it Windows 7?

from my experience:
- don't install anything into Program Files

First thing I make sure is to install Installation manager into C:/IBM/InstallationManager.
I use the C:/IBM also for shared resources.
I install CLM/RTC into something like C:/MyRTCFolder

The issue with Program files is, it is virtualized and it prevents from creating files and folders if you don't run as administrator. Even if you are logged in with administrative permissions that does not give you all the permissions on win7. You have to explicitely run from a shell you run as Admin or start the app as admin.


Comments
Richard Clayton commented Jun 20 '12, 5:53 a.m. | edited Mar 06 '13, 10:14 a.m.

Hi Ralph, Thanks for responding. 

Yes, I'm using Windows 7. 

I tried going through as Administrator - it made no difference. 

The jazz team server is installed in C:/IBM/JazzTeamServer and not Program Files. 


Ralph Schoon commented Jun 20 '12, 6:03 a.m. | edited Mar 06 '13, 10:15 a.m.
FORUM ADMINISTRATOR / FORUM MODERATOR / JAZZ DEVELOPER

Hi Richard,

this is very uncommon.
If you started it from a command line, did you see any output?  Did you consider to put a pause at the end of the server startup bat to prevent it from closing? Have you looked at the tomcat logs?


Richard Clayton commented Jun 20 '12, 6:18 a.m. | edited Mar 06 '13, 10:15 a.m.

Hi Ralph,

Below is a copy of the output when running from the command line:

Using CATALINA_BASE: C:\IBM\JazzTeamServer\server\tomcat
Using CATALINA_HOME: C:\IBM\JazzTeamServer\server\tomcat
Using CATALINA_TMPDIR: C:\IBM\JazzTeamServer\server\tomcat\temp
Using JRE_HOME: C:\IBM\JazzTeamServer\server\jre
Using CLASSPATH: C:\IBM\JazzTeamServer\server\tomcat\bin\bootstrap.jar

When running the startup bat, another command line pops up which has Tomcat written in the heading bar, but this disappears within a few seconds. 

Add a pause, shows no extra information than that above. 

No data is being written into the Tomcat logs except for the catalina log which says:

20-Jun-2012 11:12:59 org.apache.catalina.startup.Catalina stopServer
SEVERE: Catalina.stop:
java.net.ConnectException: Connection refused: connect
    at java.net.PlainSocketImpl.socketConnect(Native Method)
    at java.net.PlainSocketImpl.doConnect(PlainSocketImpl.java:393)
    at java.net.PlainSocketImpl.connectToAddress(PlainSocketImpl.java:254)
    at java.net.PlainSocketImpl.connect(PlainSocketImpl.java:241)
    at java.net.SocksSocketImpl.connect(SocksSocketImpl.java:389)
    at java.net.Socket.connect(Socket.java:556)
    at java.net.Socket.connect(Socket.java:504)
    at java.net.Socket.<init>(Socket.java:412)
    at java.net.Socket.<init>(Socket.java:226)
    at org.apache.catalina.startup.Catalina.stopServer(Catalina.java:395)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:79)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
    at java.lang.reflect.Method.invoke(Method.java:618)
    at org.apache.catalina.startup.Bootstrap.stopServer(Bootstrap.java:344)
    at org.apache.catalina.startup.Bootstrap.main(Bootstrap.java:435)




Ralph Schoon commented Jun 20 '12, 6:30 a.m. | edited Mar 06 '13, 10:15 a.m.
FORUM ADMINISTRATOR / FORUM MODERATOR / JAZZ DEVELOPER

Richard,

can you run a netstat -a and check if there are other applications listening on the ports 9009, 9443, etc?
It appears that tomcat tries to listen to a port and that does not work.

However, that can not be the only reason. I can start the server two times and the tomcat window comes up correctly and then shows the exceptions not being able to connect to the sockets. I am not sure how this happens. Do you have another machine to test? Honestly I can not remember having seen anything like this before.


Richard Clayton commented Jun 20 '12, 7:16 a.m. | edited Mar 06 '13, 10:16 a.m.

Ralph, 

From what I can tell no other applications are using ports.  I don't have any access to any other windows 7 machine at the minute


Ralph Schoon commented Jun 20 '12, 7:28 a.m. | edited Mar 06 '13, 10:16 a.m.
FORUM ADMINISTRATOR / FORUM MODERATOR / JAZZ DEVELOPER

Richard,

I am running out of options, especially because the log files are really not helping at all. Sorry for that.

I'd look at the Windows logs, if there is any indication what the cause could be.
I'd check installed Java VM - no Idea how that could impact because it should really use the one bundled
I'd consider uninstalling, deleting the install folder and reinstalling.

showing 5 of 6 show 1 more comments

permanent link
Hania Abd-El-Razik (262) | answered Jun 27 '12, 10:30 a.m.
JAZZ DEVELOPER

I've run into this problem a couple of times as well.  After adding a lot of echo's to the .bat files, I was finally able to read a message saying that there was not enough memory.  I restarted my machine and Tomcat was able to start after that.  The second time I ran into this, it was enough to close my other memory-intensive applications and run the startup script again.

Comments
Richard Clayton commented Jul 11 '12, 10:49 a.m. | edited Mar 06 '13, 10:19 a.m.

Thanks for your messages.  

I've tried starting the server with memory hungry programs turned off with no effect.  Similarly lowering the memory requirements in the the xmx setting in the start-up bat also had no effect.  Colleagues in the same office with the same spec computer haven't had any issues running the server. 

Have you any other thoughts or suggestions?

Thanks in advance,

Rich


Jin Zhou commented Mar 06 '13, 7:00 a.m.

 I met with the similar issue now, I would try your suggestion to see how thing goes.

Thank You


permanent link
Hania Abd-El-Razik (262) | answered Jul 11 '12, 11:14 a.m.
JAZZ DEVELOPER
What really helped me when I had this problem was to add echo statements to the .bat files to see how far it's getting.  In my situation, it got all the way to the end of the catalina.bat file, and I printed out the final run commands on the screen.  When I called that same command manually in a dos window, I was able to see what error was being returned since it didn't close after a split second.  Perhaps that approach would help you as well.

permanent link
Anthony Kesterton (7.5k7178136) | answered Jul 11 '12, 12:10 p.m.
JAZZ DEVELOPER
Hi Richard - did you manage to get this working?  If not - a few more things to check:

1) Disk space - do you have much disk space available - esp. the location of your TEMP environment variable.
2) When Ralph talked about starting as Administrator - he meant starting your DOS shell using the right-button "Run as administrator" option on the shell. 
3) Do you have any firewall settings preventing access to ports like 9443, 9080 and more obscure ones like 9003?
4) Does the user who installed RTC have read/write access to those c:\ibm directories and sub-dirs.  I have seen Tomcat not start if it could not write to the log files (bit of a meaningless question as you have catalina logs).

The comment about memory sizes from Scott and Hania are good points too - how much memory do you have on the machine??

Final thought - are you running Window7 Pro or Ultimate?

anthony

Comments
Richard Clayton commented Jul 11 '12, 12:54 p.m. | edited Mar 06 '13, 10:18 a.m.

Hi Adrian,

In response to your questions:

1) I have over 400GB disk space available
2) I used the 'Run as Administrator' option to start the DOS shell - I also tried running the bat file as an administrator
3) I don't think I have any firewall settings preventing access, although I'm not sure - could you advise on how I can check this?
4) I installed RTC and have administrator rights, so I have read/write access to c:\ibm and the sub-directories

I have 4GB of memory on the machine and am running Windows 7 Professional (64-Bit). 

I'll go through the bat files tomorrow and add echo statements as Hania suggested to see if I can find any clues. 

Your answer


Register or to post your answer.