It's all about the answers!

Ask a question

Post RTC installation, /jts/setup page is not opening.


PRADEEP RADHAKRISHNAN (131) | asked Sep 18 '17, 10:26 p.m.

We have successfully installated RTC 5.0.2 with the latest fix pack in to a Linux server. POst installation, we tried to configure the database using https://rtcuri/jts/setup page but the page was not opening up.

When we try to access the link, somehow the port number is getting appended with the URI, i.e. https://rtcuri:portnumber/jts/setup. Not sure how the port number is getting appended. Can someone please help us to resolve this issue?

Accepted answer


permanent link
Donald Nong (14.4k213) | answered Sep 19 '17, 1:50 a.m.

RTC 5.0.2 bundles Tomcat and its port number is 9443 by default. Some changes must have been made in your environment to allow you to access RTC through port 443. If you don't know the details, no one on this forum can actually help you.

However, you can try to access https://rtcuri and see whether you reach Apache (a reverse proxy of choice in most such cases) or Tomcat. If you can determine that a reverse proxy exists, you need to check the configuration of the reverse proxy. If you reach Tomcat directly, you need to check the server.xml file of the Tomcat deployment.

PRADEEP RADHAKRISHNAN selected this answer as the correct answer

Comments
PRADEEP RADHAKRISHNAN commented Sep 19 '17, 4:52 p.m.

Thank you so much for your reply Don. Actually we are using WAS and not TOMCAT. When I try to access the /jts/setup URL, the request is hitting F5 through port 443 and the request is getting routed to Web sever and from Web server, when the request is routed to app server, the port number is getting appended. I am not sure why the web server is appending the port number.

Currently we have RTC 5.02. running in a standalone Linux server(Old server) with the same setup and when we tried to connect to the standalone server from web server, it works fine and we are not seeing any issue. The port numbers are not getting appended. We are seeing this issue only when we try to access the application that is installed in the new server. The plan was to get rid of old Linux server once the RTC application in the new server is up and running. Any idea why the webserver appends the port number and how to resolve it?


Donald Nong commented Sep 19 '17, 8:15 p.m.

What is the "Web server"? I know that in some cases F5 can act as a reverse proxy as well. Unfortunately I don't know any details about it.

Your answer


Register or to post your answer.