It's all about the answers!

Ask a question

Can we set current plan as default when adding Plan View Widget?


Don Yang (7.2k2194127) | asked Jun 18 '12, 3:05 a.m.
retagged Jul 11 '12, 2:58 p.m. by Millard Ellingsworth (2.5k12431)
We are using RTC3013.
In Dashboard, if I add widget > CCM > plans, there are 3 existing viewlets we can add.
In Plans widget, Current plans only is set by default. But in Plan View widget, user has to select plan manually. Is there any way to set current plan for Plan View viewlet as default?


3 answers



permanent link
ankur sharma (66212228) | answered Jun 18 '12, 11:57 p.m.
JAZZ DEVELOPER
There can be multiple 'Current Plans'. Since the Plans widget can show multiple plans at a time, it can show all Current Plans by default. The Plan statistics and Plans view however can show only one specific plan and they won't know which Current Plan it should default to.

Comments
Don Yang commented Jun 19 '12, 3:46 a.m. | edited Jun 19 '12, 4:41 p.m.

Thank you very much.
I checked the results in viewlets again and your explanation does make sense.


permanent link
Surender Biyyala (401648) | answered Mar 12 '14, 4:20 p.m.
 Hi Ankur,

I have the following scenario where in we have two current plans one is related to release backlog and the other is to current sprint.

I have to create two plan view widgets on to my dashboard, where one should point to Release Backlog current plan and the other to Current sprint plan.

I really don`t know how to pass the values here as I`m trying this for first time 
could you please help me what should be the value of
the Plan and also Plan View.

In the Plan View I gave Ranked List as its value while creating the viewlet but its is not showing any value in the widget when I try to edit the parameters from dashboard.

Thanks
Surender 

permanent link
Don Yang (7.2k2194127) | answered Mar 12 '14, 7:31 p.m.
Surender

It is preferred you create a new forum discussion instead of using this old one which is talking on the different topic.
I am trying to do a quick answer to your question here and if it does not help, please create a new one and I believe it would be answered(please include the RQM version if you create a new post).
I did a test with v4.0.5 and select the sample JKE Banking and here is the result:


If you have the data in the specified plan and not seeing it in the widget, I suspect the data collection job is not run(by default, it will be run overnight)
You can go to jts/admin page > reports > data collection jobs and start the [Run all data warehouse collection jobs for all applications] , once complete, you can try again. If the collection job is configured to run overnight, you may want to see the result next morning(go to jts/admin page > reports > data collection job status and confirm it completes with no errors, go to ccm/admin > reports > data collection job status and confirm it completes with no errors) because the collection job may run in long hours and affect the performance on the daily work(that's why by default it is configure to run overnight)

hopefully this helps.


Your answer


Register or to post your answer.