It's all about the answers!

Ask a question

System i jbe or bfagent error "Not using a proxy to rea


Jia Jia Li (8057155192) | asked May 05 '12, 12:40 a.m.
retagged Jun 24 '12, 4:18 a.m. by Arne Bister (2.6k12832)
Hi,

Both Jbe and Bfagent have the same error in System i.

1. JBE

sh jbe.sh -repository https://g3rtc:9443/ccm -engineID 3GBuild -userId build -pass build -jobName JOBRTCBuild

with errors of
java.lang.NullPointerException
java.net.NoRouteToHostException: No route to host

2. BFAgent
./jbe.sh -createPasswordFile bepw.txt to generated the passwd file
edit startbfa.sh to replace JAZZ_USER, JAZZ_PASSWORD_FILE
sh startbfa.sh
In build engine, test connection passed. use port 6666
But when request the build, error log :
* default:
* Not using a proxy to reach https://g3rtc:9443/ccm/
* java.net.NoRouteToHostException: No route to host
* at java.net.PlainSocketImpl.socketConnect(Native Method)

I tried the scm tool on system i, it works well.
on system i, ping the rtc server name works well.

Anyone can help?

One answer



permanent link
Jia Jia Li (8057155192) | answered May 05 '12, 2:21 a.m.
I guess there maybe need some port open between the build agent server and rtc server?
1. build agent server scm tool works well - I think the build agent server can communicate with rtc server
2. build engine connection test works well - I think the rtc server can communicate with the build agent via port 6666

Is there any other port should be open?

Thanks!

Your answer


Register or to post your answer.


Dashboards and work items are no longer publicly available, so some links may be invalid. We now provide similar information through other means. Learn more here.