It's all about the answers!

Ask a question

Getting Invalid path to authentication servlet.: / when try to login to /ccm


Melissa Weaver (621015) | asked Sep 15 '15, 8:33 p.m.
I have seen several similar posts but none seem to answer the question, or address my circumstances. Or perhaps I just did not understand the answers correctly.   So I am posting again with more details.

I am running Jazz, RTC all on iseries  with websphere, ,  not using LDAP, 
User is in the correct user profile group  (JAZZADMINS),   User in JTS with active licenses. 
Running RTC  6.0,  WAS 8.5.5.   Was also getting on prior versions of RTC. .
Have tried both Chrome and Firefox with same results.
Tried the keep hitting 'refresh'  suggestion -  did not help

the URL we are using was working before, and has been verified as correct.  Occasionally it  does work correctly.
 
Enter the correct URL  server:port/ccm  ,  get the JAZZ login page,  enter credentials,  then get the error.  with the url listed as <server:port>/ccm/auth/
Can log in correctly if go to <server:port>/jts   and then navigate to CCM.
If open the web UI from the Eclipse client (using same URL)  it appears to always work.

Does anyone have any specific solution to this?  It is particularly annoying to not be able to go directly to the CCM web UI.   



Comments
Sean Babineau commented Sep 15 '15, 10:59 p.m.
JAZZ DEVELOPER

Hi Mel, unfortunately I don't have an instant solution. 


To clarify one point - you're not using LDAP, are you using IBM i userprofile authentication? If so, could you try upper-casing the userid?

Next, you should check the server logs to see if there's anything illuminating? On IBM i, look in: /QIBM/UserData/Websphere/Appserver/V{WebsphereVersion}/{WebSphere-edition}/profiles/{JTS_profile}/logs 
(e.g. /QIBM/UserData/WebSphere/AppServer/V855/Base/profiles/JTS60/logs ) 
Look at ccm.log, jts.log and within JTS60 directory for pertinent messages. 





Melissa Weaver commented Sep 16 '15, 5:32 p.m.

 Thanks Sean.  Yes I am using IBM i userprofile authentication.  I tried upper-casing and got the same issue.  


I looked in the logs you specified and several others and found nothing related to the login issue.  Nothing was logged at all around the time I was testing.  I did find the JTS_exception.log that has alot of  errors.  


Sean Babineau commented Sep 17 '15, 9:08 a.m.
JAZZ DEVELOPER

Could you open a PMR? 

Thanks

2 answers



permanent link
Melissa Weaver (621015) | answered Sep 18 '15, 12:46 p.m.
 Opened a PMR as suggested.  

Comments
Melissa Weaver commented Oct 05 '15, 1:53 p.m.

After more research by all, it looks like it has to do with firewalls and VPN's and how they resolve the dns names.  Thank you all for your help


permanent link
min li (52) | answered Dec 01 '15, 1:26 a.m.
JAZZ DEVELOPER
add the JTS host info into your local host file to make the host name visible to your browser.

Comments
Melissa Weaver commented Dec 01 '15, 10:56 a.m.

Thank you.  We had already done that. Seems to be an issue with our VPN's and firewalls. 

Your answer


Register or to post your answer.