It's all about the answers!

Ask a question

Built in widgets missing in dashboard.


Nick Baklanoff (1621) | asked Jun 27 '11, 1:22 a.m.
This is for RTC 3 3.0 iFix 1 (RJF-I20110307-1521). When I go to the dashboard area to add new widgets - none of the built in widgets are there... what's odd is that the widgets were there when I initially created the dashboard and I am not getting any service errors.

4 answers



permanent link
Curtis d'Entremont (1.3k3) | answered Jun 27 '11, 11:02 a.m.
FORUM MODERATOR / JAZZ DEVELOPER
Hi Nick,

I don't think I've seen this specific issue before. Could you create a work item here:
https://jazz.net/jazz/web/projects/Jazz%20Foundation#action=com.ibm.team.workitem.viewWelcome

and file it against Web UI > Dashboards. Also, if you could provide the following info in the work item it would be helpful:

- Did you check both the RTC log (ccm.log) and the JTS log (jts.log) for any errors?
- Check if your open file limit is high enough: https://www-304.ibm.com/support/docview.wss?uid=swg21403391
- Could I see a screenshot of what you see?

For a speedier resolution, another option is to provide an account I can use to log into the Web UI and I can debug the issue on the server. If you would like to do this, please send the server URL and credentials to me directly, via email. (curtispd@ca.ibm.com)

permanent link
Jared Russell (1.3k12019) | answered Jun 27 '11, 12:12 p.m.
When you say "none" of the built-in widgets are there do you literally mean *none*, or just most are missing? If it's the latter it could be that you've accidentally changed the widget catalog to use the JTS widgets rather than the CCM widgets.

This can be changed by clicking the "Add Widget" button then changing the catalog from the drop-down at the top of the widget selection frame.

This is for RTC 3 3.0 iFix 1 (RJF-I20110307-1521). When I go to the dashboard area to add new widgets - none of the built in widgets are there... what's odd is that the widgets were there when I initially created the dashboard and I am not getting any service errors.

permanent link
Nick Baklanoff (1621) | answered Jun 27 '11, 2:01 p.m.
Hi Nick,

I don't think I've seen this specific issue before. Could you create a work item here:
https://jazz.net/jazz/web/projects/Jazz%20Foundation#action=com.ibm.team.workitem.viewWelcome

and file it against Web UI > Dashboards. Also, if you could provide the following info in the work item it would be helpful:

- Did you check both the RTC log (ccm.log) and the JTS log (jts.log) for any errors?
- Check if your open file limit is high enough: https://www-304.ibm.com/support/docview.wss?uid=swg21403391
- Could I see a screenshot of what you see?

For a speedier resolution, another option is to provide an account I can use to log into the Web UI and I can debug the issue on the server. If you would like to do this, please send the server URL and credentials to me directly, via email. (curtispd@ca.ibm.com)


Yes should have checked the jts.log - output:
WebContainer : 0] ERROR service.internal.legacy.LegacyDashboardRestService - Error searching for shared dashboards
com.ibm.team.repository.common.TeamRepositoryException: The URI "https://machine:9443/jts/dashboard-query?query&size=50" cannot be the target of a request, as it is not a trusted friend.

2011-06-27 10:10:02,488 WARN net.jazz.web.app.internal.about.ConsolidatedAbout - Unable to resynconize about services: Unable to query JTS discovery :https://machinename:9443/jts/discovery?typ
e=http%3A%2F%2Fjazz.net%2Fxmlns%2Fprod%2Fjazz%2Fdiscovery%2F1.0%2FApplication: HTTP status:500:Internal Server Error

From the ccm.log:
2011-06-27 08:42:21,990 WARN net.jazz.ajax.service.sso.CookieFilter - Unable to read sso auth realm service uri:: Unable to query JTS discovery :https://wbirtc02.svl.ibm.com:9443/jts/discove
ry?type=http%3A%2F%2Fjazz.net%2Fxmlns%2Ffoundation%2F1.0%2FJAuth: HTTP status:500:Internal Server Error
2011-06-27 08:44:26,662 WARN net.jazz.web.app.internal.about.ConsolidatedAbout - Unable to resynconize about services: Unable to query JTS discovery :https://wbirtc02.svl.ibm.com:9443/jts/discovery?typ
e=http%3A%2F%2Fjazz.net%2Fxmlns%2Fprod%2Fjazz%2Fdiscovery%2F1.0%2FApplication: Timeout waiting for connection

permanent link
Nick Baklanoff (1621) | answered Jun 27 '11, 2:02 p.m.
Hi Nick,

I don't think I've seen this specific issue before. Could you create a work item here:
https://jazz.net/jazz/web/projects/Jazz%20Foundation#action=com.ibm.team.workitem.viewWelcome

and file it against Web UI > Dashboards. Also, if you could provide the following info in the work item it would be helpful:

- Did you check both the RTC log (ccm.log) and the JTS log (jts.log) for any errors?
- Check if your open file limit is high enough: https://www-304.ibm.com/support/docview.wss?uid=swg21403391
- Could I see a screenshot of what you see?

For a speedier resolution, another option is to provide an account I can use to log into the Web UI and I can debug the issue on the server. If you would like to do this, please send the server URL and credentials to me directly, via email. (curtispd@ca.ibm.com)


ulimit is unlimited.

Your answer


Register or to post your answer.