It's all about the answers!

Ask a question

CQ Connector not synching incoming work items


Shelby Phillips (29614621) | asked May 30 '08, 5:32 p.m.
At the moment, we are havings issues getting incoming synchronization to work. When building the synchronization rules, the correct "External Type" record type information is being displayed from the CQ server, as sre the "External properties" from those record types.

However, when a new record is built in CQ, no synchronization is occuring. The "cq.query" is set in configuration.properties for the CQ record type, and my work item query is searching on all work items.

Suggestions?

Shelby

11 answers



permanent link
Lorelei Ngooi (1.5k22) | answered Jun 01 '08, 8:17 p.m.
JAZZ DEVELOPER
Shelby,

I think I recall from a previous thread that you are using Beta2. We would recommend that you upgrade to at least Beta3 or to RC4 since we have made a number of improvements and bug fixes since Beta2.

If I understand your issue correctly, you are saying that you can see the CQ record type as one of the external types in the sync rule editor but you are unable to sync a CQ record of that type. I would verify that the cqconnector.properties file has an entry for cq.query.<recordType> where recordType is the CQ record type that you want to sync. Also run the CQ Gateway Status page to see the state of the CQ gateway.

This property is no longer supported in RC4. That may also be the case in Beta3, I'll need to verify that. It is being replaced by the cq.queryTreeRoot property.

Lorelei
Jazz CQ Connector Team

permanent link
Shelby Phillips (29614621) | answered Jun 03 '08, 10:54 a.m.
We are actually on Beta3 at the moment, and I can verify that the cq.query field has been created in the .properties file. The CQ Gateway is also showing successful connectivity.

Any other suggestions?

Also - I am not familiar with RC4. Could you explain this?

Shelby

permanent link
Richard Piazza (381) | answered Jun 03 '08, 11:42 a.m.
JAZZ DEVELOPER
A few suggestions to help you (and us) debug....

First, start the gateway with DEBUG logging on. This is done by commenting out two lines in the log4j.properties file in the gateway directory:

log4j.logger.com.ibm.rational.interop.level1=DEBUG
log4j.logger.com.ibm.rational.interop.level2=DEBUG

(also comment out the line above these two).

Additionally, create a CQ query on the record type JazzConnectorChangeEvents. Without the gateway running, create a CQ defect, and see if a change event is generated.

Rich Piazza
Jazz CQ Connector team

permanent link
Shelby Phillips (29614621) | answered Jun 11 '08, 10:50 a.m.
The synchronization issue was solved by creating a custom record type query and placing it in the following folder within CQ:

Public Queries\Jazz ClearQuest Connector\<Project_area_name\

permanent link
Lorelei Ngooi (1.5k22) | answered Jun 11 '08, 1:20 p.m.
JAZZ DEVELOPER
Good to hear that you were able to resolve your incoming sync problem. A CQ folder with the project area name is required for incoming sync to occur. A query is necessary if you want to select which records of the record type are synched. If no query is specified, then all records of that type will be synced.

Lorelei

permanent link
Bussiere Mathieu (6) | answered Jun 12 '08, 11:27 p.m.
Hi, I just want to know if the "<Project_area_name>" is the name of the query or the name of a folder?

Public Queries\Jazz ClearQuest Connector\<Project_area_name[/code:1:16197f7938]


Because a got another problem, the field "External Type" is always empty when I create a new Sync rule.

Thanks

permanent link
Lorelei Ngooi (1.5k22) | answered Jun 13 '08, 1:57 p.m.
JAZZ DEVELOPER
<Project> is the name of the CQ folder.

The problem that you are having with the empty external type field is unrelated to the query folder structure in CQ. Make sure you have the CQ gateway running. In the sync rule editor, make sure the external repository and the external manager fields are set. The external type field should be populated with the CQ record types that you have enabled to be CQ connector-enabled.

If this is not the case, then maybe when applying the JazzInterop package to your CQ schema, you hadn't specified which CQ record types you wanted to synchronize with RTC or forgot to upgrade the user database.

If you are using the sample DefectTrackingInterop schema, maybe you forgot to upgrade the user database.

Lorelei

permanent link
Lorelei Ngooi (1.5k22) | answered Jun 13 '08, 2:02 p.m.
JAZZ DEVELOPER
<Project> should be <ProjectAreaName>

permanent link
Shelby Phillips (29614621) | answered Jun 17 '08, 6:48 p.m.
Please note that in RC5, the public query will now need to read "JazzConnector" , all one word and NOT "Jazz ClearQuest Connector"

permanent link
Lorelei Ngooi (1.5k22) | answered Jun 17 '08, 7:05 p.m.
JAZZ DEVELOPER
Hi Shelby,

Are you referring to the value of the cq.queryTreeRoot property in the cqconnector.properties file? It can have the path to any query folder below the Public Queries or Private Queries folder as long as it is consistent with the folder that you created in CQ. So if you created a query folder under the Public Queries folder named "Jazz ClearQuest Connector", then just make sure the value of the cq.queryTreeRoot property is "Public Queries/Jazz ClearQuest Connector". By default, the value of that property is "Public Queries/JazzConnector". See the https://jazz.net/jazzdocs/topic/com.ibm.team.connector.cq.doc/topics/t_creating_query_hierarchy.html topic for more info on that property.

By the way, do you know if empty external type problem has been resolved?

Lorelei

Your answer


Register or to post your answer.