It's all about the answers!

Ask a question

Trouble with source control in VS2010


Daan van der Munnik (29113127) | asked Jan 26 '11, 10:55 a.m.
When activating source control in VS2010 (Ultimate), I get the following error:
(changed actual url into "mydomain")

01-26-2011 16:49:49 ServiceInterfaceProxy: Request 26: com.ibm.team.repository.TeamRepositoryException: CRJAZ1368E The URL "https://jazz.mydomain.net:9443/jazz/versionCompatibility?clientVersion=3.0" cannot be reached. The network stated the URL is invalid. The error is "java.nio.channels.UnresolvedAddressException". Verify the URL and contact your administrator. ---> com.ibm.team.repository.TeamRepositoryException: Unspecified problem.

verbose logging shows:

com.ibm.team.repository.common.transport.HostUnknownException
Request URI:
http://localhost:6421/service/com.ibm.team.filesystem.client.rest.IFilesystemRestClient/Login

Second error makes me think this is not a server issue, but has something to do with the client (is a local daemon running ?).
Also the RTC from eclipse and web-ui work fine.

Thanks,

Daan.

8 answers



permanent link
Daan van der Munnik (29113127) | answered Jan 27 '11, 11:24 a.m.
Looks like this has something to do with being behind a proxy server.
When using this from a location connected without the proxy server, source control works fine.

Appearantly part of the VS integration uses the proxy settings configured in windows, while the scm daemon does not use this.

Is this a bug or am I able to configure this somewhere ?

Thanks,

Daan.

permanent link
Daan van der Munnik (29113127) | answered Jan 31 '11, 7:53 a.m.
Based on earlier topics in this forum I now added the https_proxy environment variable. This fixes the issue when executing scmtools from the command line (like "scm list streams").

However it does not fix the issue in the Visual Studio IDE.

Any suggestions ??

permanent link
Prabodh Mairh (3812) | answered Feb 01 '11, 1:34 a.m.
FORUM MODERATOR / JAZZ DEVELOPER
Based on earlier topics in this forum I now added the https_proxy environment variable. This fixes the issue when executing scmtools from the command line (like "scm list streams").

However it does not fix the issue in the Visual Studio IDE.

Any suggestions ??


From the error message, I was wondering it might be a firewall setting issue. If you are behind a firewall, try adding the jazz server URL as a "trusted site" in the firewall settings, and then try.

Are you getting this error message when you login to repository thorugh visual studio client, or while doing some scm related operations like say, check in, deliver, accept, load etc.?

permanent link
Daan van der Munnik (29113127) | answered Feb 01 '11, 6:26 a.m.
Are you getting this error message when you login to repository thorugh visual studio client, or while doing some scm related operations like say, check in, deliver, accept, load etc.?


The error is related to source control inside VS only. If I disable jazz source control in the visual studio settings, everything else works fine (workitems etc.).

Once jazz source control is enabled in VS, when logging in, the dialog says "synchronizing the daemon's login state" after which the above error pops up (invalid url).

As the commandline scm client also gave a similar error whithout the https_proxy environment variable set (and everything works fine when I connect from outside our office environment) this gave me the impression that it has something to do with proxy settings in the scm client while running in daemon mode...

I can send additional logging if you require this...

Thanks,

Daan.

permanent link
Evan Hughes (2.4k1018) | answered Feb 07 '11, 11:33 a.m.
JAZZ DEVELOPER
If you can find a way to smuggle the environment variable into the daemon, you should be able to connect.

I'm not familiar with the facilities Windows provides for managing environment variables, but I suspect you should be able to a set global environment variable, or something specific to VS (which will hopefully be passed to any process VS starts).

--
Evan Hughes
Jazz Source Control

permanent link
Evan Hughes (2.4k1018) | answered Feb 07 '11, 11:43 a.m.
JAZZ DEVELOPER
I've created bug 152668 to track this.

Please post follow-ups there.

--
Evan Hughes
Jazz Source Control

permanent link
Daan van der Munnik (29113127) | answered Mar 08 '11, 11:25 a.m.
I've created bug 152668 to track this.


The consensus of this workitems looked to me that some fix was needed in the VS client to query the IE proxy settings. However the work-item is now closed with status "works for me" ?

Is this followed up somewhere else ?

It is actually a pretty important showstopper for us, as we cannot start implementing the visual studio client in our environment at this time...

Thanks,

Daan.

permanent link
Sreerupa Sen (1.0k4) | answered Apr 28 '11, 1:37 p.m.
FORUM MODERATOR / JAZZ DEVELOPER
Hi Daan,
You probably know this already from the work item, but just to close the loop on this one, the VS Client does support authenticating via proxies in 3.0.1 Beta 3 which was released a couple of weeks ago.

regards
--Rupa

Your answer


Register or to post your answer.