It's all about the answers!

Ask a question

Complexity progress in Release Plans is not updated


Dave Harrison (1111) | asked Apr 19 '10, 9:02 a.m.
Hi, I am using RTC 2.0.0.2 iFix1. I have read most (if not all) of the threads I can find on this but if I have missed the solution please redirect me and accept my apologies...

I am attempting to adapt an OpenUp process to include complexity in the Release plans, to summarize progress in the underlying execution items. Estimates and hourly progress are reported correctly in the iteration plans. This is part of fairly established system, so changing the process to a SCRUM variant is not really an option.

I have defined at top-level WI with a number of child execution WIs. I have tried defining the complexity metric as an enumeration, bound to the top-level WI as a custom attribute. Alternatively I tried to bind it as an integer custom attribute of the top-level WI, since the enumerations appear to be stored as strings in the configuration source. I have set the Complexity Attribute in the "Plan Attributes" and can see the different types reflected in the release plans, so am sure that these are correctly bound. There is only the one timeline in use, to which the team doing the work is assigned.

Despite this, as work progresses in the sub-tasks - showing the progress correctly in the iteration views, the Progress Reports for Release Plans remain stubbornly blank. For example - I have complexity 6 with 6/12 hours completed, I think I am correct to expect 3/6 complexity to be completed but I see 0/6.

Is there some other link between the execution/top-level tasks to be defined? Have I gone about the complexity definition incorrectly? Any suggestions as to how to fix this linking would be so gratefully received...

Thanks

Be the first one to answer this question!


Register or to post your answer.