It's all about the answers!

Ask a question

Has anyone successfully configured CLM on Oracle RDS from AWS?

Ryan McBryde (5511026) | asked Mar 17, 3:15 p.m.

Yes, is out of support.

I am trying to upgrade to 7.0.2 but I am using SQL Server and I can't run RDNG 7.0.2 on SQL Server, so I have to migrate the databases over to Oracle.  We have the apps running on AWS EC2 and we currently have the databases on SQL Server 2014 RDS.  The Oracle RDS has been created and the necessary databases as well.  The databases have been set up with data encryption so certificates come into the picture.

We keep running into this error:

The server was unable to connect to the database because the database connection settings are invalid or because database is unreachable (SQLSTATE: 08006, SQLCODE: 17002). Verify the connection settings in your file.

The connection string referenced:<DBNAME>/{password}@//<SID>

Has anyone successfully set up CLM or 7.0.2 using secured Oracle RDS?

Ian Barnard commented 2 days ago

See the docs - that topic doesn't exist for but might be worth trying?


Ryan McBryde commented 2 days ago

Thanks Ian,

I am looking at that article and it is helpful.  I was hoping that in the vast universe of Rational users that there was someone who had it working with either or 7.0.2. 

David Honey commented yesterday

Have you tried DBeaver to see if you can successfully connect through JDBC?

Ryan McBryde commented 16 hours ago

I have used DB Visualizer to successfully ping the host and port but cannot connect.  I think it's an issue with certificates, ewallet files, etc. as described here:

Doesn't seem to work with RDS however. 

2 answers

permanent link
David Elliott (111) | answered yesterday

 Yes I tried to configured but didn't work then get fixed this way. You need to migrate your databases over to Oracle. However, you are encountering an error when trying to connect to the Oracle RDS, and you are wondering if anyone has successfully set up CLM on secured Oracle RDS.

It's difficult to provide a specific solution without more information about your setup and configuration, but here are some general tips and suggestions that may help:

Verify that the connection settings in your file are correct and match the connection details for your Oracle RDS instance. Make sure that the hostname, port number, and SID are correct.

Check that your Oracle RDS instance is reachable from your AWS EC2 instance. You may need to adjust your security groups or network ACLs to allow traffic between the two instances.

Verify that the SSL/TLS certificate used by your Oracle RDS instance is valid and trusted by your Java environment. You may need to import the certificate into your Java keystore if it's not already included.

Double-check that the username and password for your Oracle RDS instance are correct and that the necessary permissions have been granted to the user.

Make sure that your Oracle RDS instance is configured to accept connections over the thin JDBC driver. You may need to adjust the listener settings or open the necessary ports to allow JDBC connections.

Consult the IBM Rational CLM System Requirements and the Oracle RDS documentation for guidance on configuring CLM on Oracle RDS.

Overall, migrating your databases from SQL Server to Oracle RDS and configuring a secure connection can be a complex process, and it's recommended to seek the assistance of a qualified DBA or consultant if you're not familiar with the technology or configuration. 

Ryan McBryde commented 16 hours ago


Thank you.

I have confirmed with IBM that the connection string is correct and includes the correct hostname, port number, and SID.

"Reachable" may be the problem.  I can ping it successfully on port 1521, which I understand indicates that the listener is listening.

"Certificate"  is what I am thinking is the source of the problem.  Which cert and where does it get added, to the Liberty keystore?

I have been reviewing the instructions that IBM provides for 7.0.2 but have not been able to successfully create the ewallet file and cannot convert it because the RDS doesn't have an "orapki" command available.  Difference between an RDS and an actual DB server. 

I have a ticket open and I am working with my engineers and DBA, but interestingly, tech support was the one that recommended posting on the forum.  

permanent link
Ian Barnard (1.5k613) | answered yesterday
edited 5 hours ago
First try the steps documented for 7.0.2 which may work for older versions:

Something else you could try, based on experience with getting a secured connection to SQL Server: I had to update the jre to get it to work. I think this is because the SSL/TLS implementation is in JRE and there have been changes since  - sorry, I don't have more detail.

Obviously care is needed replacing the JRE so get a backup of everything first! Strongly suggest doing this in a test environment first!

To update: Download the jre archive from the link above, delete the jre folder in and copy over from the archive

Run java -version to confirm it's the new version

Then the SSL connection will hopefully work.

Your answer

Register or to post your answer.