It's all about the answers!

Ask a question

RPE not Accessing DOORS Next Modules


Calum Button (132) | asked Nov 22, 11:22 a.m.

I have an RPE template to extract artifacts from a DOORS Next module.  It has been working fine on some simple modules I created but is now not working on new modules.


If using the project and module URI's in the specification it seems to access only one element, the module and produces a blank document.  If I remove the module URI it will go through all the artifacts in the project and exports them to Word.

I'd appreciate any advice on this, I believe the new modules might be under Global Config if that has any affect?


Comments
Calum Button commented Nov 23, 3:56 a.m. | edited Nov 26, 11:47 a.m.

Further to my original post, I have found that when I use the module URIs, for the modules I am unable to export, to display the module XML there is no data displayed, just the following line:

<ds:dataSource xmlns:ds="http://jazz.net/xmlns/alm/rm/datasource/v0.1" appId="RRC" totalCount="0" vMajor="60" vMinor="06"/>

When I do the same for modules that do export I get all the module data displayed, would anyone be able to explain why this might be happening or how I get the correct URI for those modules not being displayed?

Accepted answer


permanent link
Chandan M B (752059) | answered Nov 24, 12:59 p.m.
Calum Button selected this answer as the correct answer

Comments
Chandan M B commented Nov 25, 7:39 a.m.

Technically that shouldn't be the problem. Reportable Rest API never always enforced oslc config context. Context is just to ensure the data and links in which you work on (It can be local or GC configuration)


Chandan M B commented Nov 25, 7:45 a.m. | edited unknown

Technically that shouldn't be the problem. Reportable Rest API never always enforced oslc config context. Context is just to ensure the data and links in which you work on (It can be local or GC configuration) 


Chandan M B commented Nov 25, 7:46 a.m. | edited unknown

Technically that shouldn't be the problem. Reportable Rest API never always enforced oslc config context. Context is just to ensure the data and links in which you work on (It can be local or GC configuration)


Chandan M B commented Nov 25, 7:49 a.m. | edited Nov 26, 11:48 a.m.
I am not able to comment so adding as an answer
------
Technically that shouldn't be the problem. Reportable Rest API never always enforced oslc config context. Context is just to ensure the data and links in which you work on (It can be local or GC configuration)

1
Calum Button commented Nov 25, 9:25 a.m.

Okay, thanks, we'll make a note for users to watch for it and use the format you sent. 


Ian Barnard commented Nov 25, 12:57 p.m.
JAZZ DEVELOPER

Yes not providing a configuration means your query will go to the default configuration - which may not have the module in it so you get zero results. 


Calum Button commented Nov 26, 6:02 a.m.

Thanks for your reply Ian,


I come from a DOORS Classic background, is that akin to not selecting a baseline then?
Equally, if I've imported a module from Classic to Next why would the module with data not be the default configuration, it seems to be if I create a module?

Sorry if they're schoolboy questions, but I'm finding the move from Classic to Next unnecessarily difficult :-)


Geoffrey Clemm commented Nov 26, 11:53 a.m.
FORUM ADMINISTRATOR / FORUM MODERATOR / JAZZ DEVELOPER

The "default configuration" for DNG is just the "Initial Stream" ...  so your imported data will be in the default configuration if you imported it into the Initial Stream.


Note that I am violently against the concept of a "default configuration" ... the only purpose of this concept is to allow configuration unaware integrations (which do not specify a configuration) to appear to continue to "work" when configuration management is turned on.   But unless the user only works with the Initial Stream (in which case, why turn on full configuration management at all?), the "default configuration" will usually just be the wrong configuration, resulting in the kind of justifiable confusion you are experiencing here.

showing 5 of 8 show 3 more comments

One other answer



permanent link
Calum Button (132) | answered Nov 25, 6:54 a.m.
edited Nov 25, 10:10 a.m.

Thank you, that seems to work.

Would you be able to explain why this works but the format:
doesn't work for some modules?  Is it due to configuration?

Your answer


Register or to post your answer.