It's all about the answers!

Ask a question

what oauth timeout setting do I need to increase for > 60 minutes doc generation in RPE?


David Clark (224533) | asked Jul 09 '21, 10:38 a.m.

 I am building a large trace matrix and it is taking a long time. It is currently 4 documents deep and I need to add several more documents.

I am using RPE to generate the trace matrix, but it keeps running into an Oauth error around 3662 seconds (approx 60 minutes).
I looked at the Jazz Server settings and did not see any obvious timeouts.
Looking at the RM settings there are a couple of time outs around the 3600 seconds mark.
JDBC Connection Max Age
SPARQL Query
DNG WebUI Comm
changeset.socket

Will one of these address my issue?

Thanks,

2 answers



permanent link
David Clark (224533) | answered Jul 15 '21, 10:04 a.m.

 Turns out I just needed to set the authentication to OAuth and not Auto. It took  1hr and 12 minutes to generate, but it finally did.

The REST API from RPE to DNG is soooooo slow...


permanent link
Bartosz Chrabski (3.3k12141) | answered Jul 09 '21, 10:43 a.m.

 Check SSO Session Timeout it is parameter for every application.


I assume You are not using Jazz Authorization Server.


Comments
David Clark commented Jul 09 '21, 10:50 a.m. | edited Jul 09 '21, 10:52 a.m.

The SSO timeout is set to 7200 - somethings, the hover help does not indicate the time units. 

But 7200 does not fit into the time frames I am seeing whether - if in seconds, then that is 2 hrs and I am distinctly dropping at the 1 hour mark, and in MS that is only 7.2 sec.


Subramanya Prasad Pilar commented Jul 12 '21, 7:08 a.m.

Is it behind proxy? You may need to check proxy settings as well.

Your answer


Register or to post your answer.