It's all about the answers!

Ask a question

RM project area Enable Configuration Management greyed out?


Sean F (1.3k22560) | asked Mar 17, 10:53 a.m.
I have enabled CM in the server advanced properties using the key from the IBM website.

I have then created a Lifecycle project (based on SAFe) with an RM project area (+CCM + QM).

I am logged in as a member with 'admin' and 'configuration lead' roles.

This member is also in the list of Administrators for the RM project area.

Why is the Enable Configuration Management button under RM Manage This Project Area greyed out?

I tried creating a standalone RM Project Area but this also has the Enable Configuration Management greyed out

I also tried restarting the server and the machine

The server admin area seems to have accepted the key for CM enablement without complaint.

Standalone trial V606

Accepted answer


permanent link
Ian Barnard (895612) | answered Mar 17, 12:06 p.m.
JAZZ DEVELOPER

Hi Sean


Did you put the key in the RM application advanced properties? If not, that's where it should go, same for QM.

Regards
Ian

Sean F selected this answer as the correct answer

Comments
Sean F commented Mar 17, 12:54 p.m. | edited Mar 17, 12:55 p.m.
Thanks Ian

The last time I did this was on 604 I think

In the notes i took at the time I only put the key in the server advanced properties

Just wondering if it changed or if my notes are faulty.

I have now enabled it separately in RM QM and CCM after first having enabled it only in JTS

Also wondering what is the meaning of enabling it in JTS if it needs to be separately enabled for each application?

Ian Barnard commented Mar 17, 2:21 p.m. | edited Mar 17, 2:21 p.m.
JAZZ DEVELOPER

I think it's just a property by Foundation so it shows up on JTS as well as the apps, but the apps advanced properties is where the key has to be put. Don't believe there's any point putting it into CCM.


Davyd Norris commented Mar 17, 5:25 p.m.

@Sean F - yes you do need to explicitly add the key to each application through the Advanced Properties. This is because it's possible to have multiple application servers of the same type with some enabled and some not - as Ian says, the property showing in JTS is just a hang over.


Sean F commented Mar 18, 8:02 a.m.
^^Thanks again Ian
^Thanks Davyd

Your answer


Register or to post your answer.