It's all about the answers!

Ask a question

RQM Record Test Script Error

Abhishek Kumar (49822) | asked Apr 21 '20, 6:40 a.m.
edited Apr 21 '20, 6:44 a.m.


RQM Version RFT Adapter Version

Created a test script with a manual step and wanted to add additional steps via the recording. I have configured the RFT adapter, but on pressing the recording option in RQM the following message is generated in the logs: 

10:18:41,255 [Record Thread] ERROR - Error while linking to the manual script in RQM: Failed to send data Failed to send data 
at Caused by: POST[400] : <?xml version="1.0" encoding="UTF-8" standalone="yes"?><ns2:Error xmlns:ns2="" xmlns:ns1="" xmlns:ns4="" xmlns:ns3="" xmlns:ns6="" xmlns:ns20="" xmlns:ns5="" xmlns:ns8="" xmlns:ns7="" xmlns:ns13="" xmlns:ns9="" xmlns:ns12="" xmlns:ns11="" xmlns:ns10="" xmlns:ns21="" xmlns:ns17="" xmlns:ns16="" xmlns:ns15="" xmlns:ns14="" xmlns:ns18=""><ns2:statusCode>400</ns2:statusCode><ns2:message>Required property 'steps' is missing.</ns2:message></ns2:Error> 
... 4 more 10:18:41,259 [Record Thread] ERROR                            - Error while linking to the manual script in RQM: Failed to send data Error while linking to the manual script in RQM: Failed to send data 
at 10:18:41,259 [Record Thread] DEBUG           - Start internalSendToServer[,<?xml version="1.0" encoding="utf-8"?> <qm:adaptertask   xmlns:app=""  xmlns:qmresult=""  xmlns:a=""  xmlns:alm=""  xmlns:qmtask=""  xmlns:qmtestscript=""  xmlns:abdera=""  xmlns:xhtml=""  xmlns:rqm=""  xmlns:qmadapter=""  xmlns:rqmversion=""  xmlns:rdf=""  xmlns:qmtsl=""  xmlns:qm=""  xmlns:atom=""  xmlns:dc="" > <qmtask:progress>100</qmtask:progress><alm:state></alm:state><qmtask:statusCode>200</qmtask:statusCode><qmtask:message>Error while linking to the manual script in RQM</qmtask:message></qm:adaptertask>]

Looking forward for any leads in debugging this.

Thanks in Advance.

2 answers

permanent link
abhishek gour (3812) | answered Apr 21 '20, 8:04 a.m.
RFT looks to be newer version. Have you tried using this with ETM 7.0 (

Could you please talk to IBM support team ( or RFT support team ) to file a possible defect in this regard. RFT compatibility with RQM 6061 has to be validated.

Also from your logs ->

permanent link
abhishek gour (3812) | answered Apr 21 '20, 8:07 a.m.

From you logs ->

property 'steps' is missing.</ns2:message></ns2:Error> 

Test Script Steps should not be missing while updating test script via adapter, This may help you in some way.

Abhishek Kumar commented Apr 21 '20, 8:50 a.m.

I have tried  RFT V10.0.0 RQM  and RQM 6.0.6 ifix 007 also, it results in the same error message.

When i looked at this error message i searched the forum and came across this question:

Following Paul's comments i created a manual step, but still the error message is the same. So i am stuck.

Abhishek Kumar commented Apr 21 '20, 8:55 a.m.

 Even the QM logs generate the same error messge:

2020-04-21 12:52:52,962 [Default Executor-thread-1278842 @@ 12:52 <unauthenticated> <RQMConnectionHelper/v0.1 spnego-enabled spnego-enabled@> /qm/service/] ERROR                               - Required property 'steps' is missing.

abhishek gour commented Apr 22 '20, 4:01 a.m.
It may be an issue from RFT side. Some one may need to check if the data which is sent to Adpater contains the step information or not.

Do you have access to the Data which is being sent via RFTRecordThread to QM?
You could try to perform POST/PUT to your QM server with that data to check if QM is wrongly responding an error to request or it is the data has some missing info.

Your answer

Register or to post your answer.

Dashboards and work items are no longer publicly available, so some links may be invalid. We now provide similar information through other means. Learn more here.