It's all about the answers!

Ask a question

Unable to install RTC client on Eclipse on Macbook


Anthony Randolph (4113) | asked Oct 09 '19, 2:18 p.m.
edited Oct 10 '19, 4:01 p.m.

 I am new to the Macbook world (Mojave v10.14.6), I am trying to install RTC client (v 6.0.2 and v5.0.2) on Eclipse (versions Photon and Oxygen). I get the following error:  "Could not find file:file:/<eclipse install>/jazz"


I verified that everyone has Read/Write permission to the directory that the "RTC-Client-Mac-6.0.2.zip" zip file was extracted to:
drwxrwxrwx@  6 <userid>  staff        192 Oct  4 16:52 jazz


I also tired to point directly to the archive file and I get the same error message.

From reviewing the eclipse .log file I see the following trace, which still doesn't provide me any good information:
!ENTRY org.eclipse.equinox.p2.core 4 0 2019-10-09 11:06:54.65
!MESSAGE Provisioning exception
!STACK 1
org.eclipse.equinox.p2.core.ProvisionException: No repository found at file:/<eclipse install>/jazz/.
...
!MESSAGE No repository found at file:/<eclipse install>/jazz/.
PLEASE HELP!! I am not sure what else to check or how to proceed to get an RTC Client installed on my new Mackbook Pro. 

Regards Anthony R.

<style type="text/css"> p.p1 {margin: 0.0px 0.0px 0.0px 0.0px; font: 11.0px Menlo; color: #000000} span.s1 {font-variant-ligatures: no-common-ligatures} </style>

One answer



permanent link
Ian Wark (79713551) | answered Oct 15 '19, 7:05 p.m.

I think you may be using the wrong steps. The RTC-Client-Mac-6.0.2.zip is supposed to be just unzipped and ready to use AFAIK. However, I am not sure all the necessary content is in the MacBook media for 6.0.2. I have also had trouble with this media.

Option 1
Use IBM Installation Manager and download the Client for Eclipse 3.6.x IDE or Client for Eclipse 4.2.x IDE (see further up the page under IBM Installation Manager Repositories). https://jazz.net/downloads/rational-team-concert/releases/6.0.2?p=allDownloads. Set the repository.config file from the unzipped RTC Eclipse client media as a repository to IBM Installation Manager and install. Mojave 10.14 appears to be supported.

Option 2
You install from eclipse.org a supported version of the Eclipse client. Oxygen is 4.7 and Photon is 4.8, and the latest supported for 6.0.2 is 4.5.2 so unfortunately these versions are not supported until a more recent RTC version. Go for just the vanilla version of Eclipse with e.g. Java IDE. See here for a link to the Mars 2 version of Eclipse. https://www.eclipse.org/downloads/download.php?file=/technology/epp/downloads/release/mars/2/eclipse-java-mars-2-macosx-cocoa-x86_64.tar.gz. See here for the compatibility reports. https://www.ibm.com/software/reports/compatibility/clarity-reports/report/html/softwareReqsForProduct

Then you add the RTC Eclipse p2 repository zip as an install location for your Mars 2 Eclipse and install using Eclipse itself. The p2 zip is available from the same download page as the other Eclipse media. https://jazz.net/downloads/rational-team-concert/releases/6.0.2/RTC-Client-p2Repo-6.0.2.zip

Your answer


Register or to post your answer.


Dashboards and work items are no longer publicly available, so some links may be invalid. We now provide similar information through other means. Learn more here.