It's all about the answers!

Ask a question

Plugin to move work items between project areas not working


Ian Wark (6282540) | asked Jul 08, 1:36 a.m.
edited Jul 08, 1:40 a.m.

We have installed the set of three plugins from

https://github.com/jazz-community/rtc-workitem-bulk-mover-ui


We installed using the 1.5.2 versions in two environments. CLM 6.0.4 and CLM 6.0.6.

com.siemens.bt.jazz.services.WorkItemBulkMover.updatesite-1.5.2

com.siemens.bt.jazz.ui.WorkItemBulkMover.menuProvider_1.5.2

com.siemens.bt.jazz.ui.WorkItemBulkMover_1.5.2


​Our installation steps are to unzip and use the folder in each of the 3x plugins in the

C:\IBM\JazzTeamServer\server\conf\ccm\sites directory. (The folder names don't have the 1.5.2 bit on the end.)


We put the 3x update site text files in the below directory:

C:\IBM\JazzTeamServer\server\conf\ccm\provision_profiles

After restarting the server there is a new Add-ons menu link displayed. If you click it there is a button displayed with a swirling busy-like icon. Clicking the button opens a work item query selection dialog. We selected a query that we knew would return results, but get the message:

"The query did not return any result. JSON.parse: unexpected character at line 1 column 1 of the JSON data"

Error message

Did we install the set of plugins correctly? Is this plugin broken?


Comments
Ian Wark commented Jul 08, 1:54 a.m.

Note that we ran https://server-address/ccm/admin/cmd/requestReset and restarted the server once more to check if it made a difference, but no joy.

One answer



permanent link
Lukas Steiger (2781421) | answered Jul 08, 8:51 a.m.

Dear Ian,


Thank you for the detailed explanation. 
As per your provided screen shot, the Menu Provider and UI plug-in have been successfully installed. The grey text on the right hand side of 'Version 1.5.2" would normally show the version of the service, but in your case the Service seems not to be running, as '<unknown>' is shown. 

Please check the following:
- Navigate to   https://server-address/ccm/service  and search for 'WorkitemBulkMover' or 'com.siemens.' If the service is NOT listed here, which what I expect, then the installation failed
- Check the CCM log around the time when you last tried to install the plug-ins. Search again for entries like 'WorkItemBulkMover' or 'com.siemens'. They might give you an indication why the deployment has failed.

(I had to provide this as answer as the comment length is limited)


Comments
Ian Wark commented Jul 10, 10:03 p.m.

Thanks for the detailed help. I ran the /ccm/service and could find the service installed. It is listed as Component ID com.siemens.bt.jazz.services.WorkItemBulkMover and URI Alias com.siemens.bt.jazz.services.WorkItemBulkMover.IWorkItemBulkMoverService.


I did find an error in ccm.log about install of the service. The error is saying it could not install a dependent bundle com.ibm.team.workitem.service. I am going to try restarting the server again and make sure it is still relevant. But it looks relevant..

2019-07-07 22:49:26,222 [       Launch callback handler] ERROR eam.repository.provision.internal.ProvisionService  - CRJAZ0288E 「com.siemens.bt.jazz.services.WorkItemBulkMover.feature」プロファイル・フィーチャーを、「C:\IBM\JAZZTE~1\server\conf\ccm\provision_profiles\com.siemens.bt.jazz.services.WorkItemBulkMover-update-site.ini」プロファイル・ファイルで参照されている「file:ccm/sites/com.siemens.bt.jazz.services.WorkItemBulkMover-update-site」更新サイトからインストールできませんでした。
com.ibm.team.repository.provision.ProvisionException: CRJAZ0281E 「com.ibm.team.workitem.service」依存関係バンドルをインストールできません。


Ian Wark commented Jul 10, 10:39 p.m.
OK. There is no error in ccm.log after restart. And we can definitely see the service interface com.siemens.bt.jazz.services.WorkItemBulkMover.IWorkItemBulkMoverService is installed from /ccm/service. But the screen capture is the same. Here is what it looks like before we click the button. I think it is not correct. I think there might be a problem with the plugin on CLM 6.0.6? Could you check?

Initial screen

Ian Wark commented Jul 12, 2:32 a.m.

Lukas, are you still there? Could you help us out?


Lukas Steiger commented Jul 12, 4:35 a.m.

Dear ian, thank you for the feedback provided. Yesterday, I found out that this is a browser related issue. I already have a fix in place for this one, but there is another encoding related topic that I want to fix as well so that it then should work for you. I will be providing a fix the beginning of next week. 


Lukas Steiger commented Jul 16, 7:37 a.m.

 Dear Ian,

I have just published a new version of the UI and Service. They should now fix your issues:
https://github.com/jazz-community/rtc-workitem-bulk-mover-ui/releases/tag/v1.5.3

Please let me know if things work for you now, so that I can close the respective issue.

Thanks in advance for your feedback.

Your answer


Register or to post your answer.