It's all about the answers!

Ask a question

IBM Rational Team Concert 6.x Extensibility Workshop Jetty CALs not available ( RTC 6.0.3 )


Don Cooper (1617) | asked Feb 20 '19, 2:21 p.m.
Everything went fine installing the workshop until I got to the Jetty server CALs.

Jetty server is up and running, RTC loads on port 7443, but there are no CALs available. The startup logs show:

WARN repository.service.internal.license.LicenseService  - CRJAZ0942I The license key located at "bundleentry://208.fwk2130772866/active/RTC_Developer_Trial.jar" could not be processed. For the cause of the problem, see the nested exception.
com.ibm.team.repository.common.TeamRepositoryException: CRJAZ0965I The file was not a valid server or client access license activation key.

com.ibm.team.licensing.product.rtc-standalone bundle is loaded with trial licenses but they don't show up in RTC.

I tried uploading the RTC-Developer-10-C-License-6.0.3.zip directly but it says there are no keys in it.

I downloaded licenses from my company's entitlements but it says they are not compatible with the development server.

Accepted answer


permanent link
Ralph Schoon (59.7k23643) | answered Feb 21 '19, 2:37 a.m.
FORUM ADMINISTRATOR / FORUM MODERATOR / JAZZ DEVELOPER

I have never seen this. You should have temporary licenses available if you followed the workshop carefully. If you can not enable them, you have likely forgotten to install the trial licenses when using Installation Manager. Use the ZIP version. Note: Use a current JDK and not the JDK shipped with the server.


I know that some versions of RTC had issues with importing the licenses from zip files. You can try to extract the zip file and to import from the extracted folder instead of the zip file.

Don Cooper selected this answer as the correct answer

Comments
Don Cooper commented Feb 21 '19, 4:06 a.m.
I didn't use installation manager.

I imported the RTCDeveloper-10-C-License-6.0.3.zip into the RTC Development server no problem, and the licenses are available there.

It's my understanding the com.ibm.team.licensing.product.rtc-standalone "The RTC Product (Trial) Licenses 0.9.9"  bundle contains the CALs for the Jetty Debug launch. I have that bundle imported and is included in the bundles for the [RTCExt Jetty RTC Server launch]. It finds the bundle but cannot process it. CRJAZ0942I The license key located at "bundleentry://208.fwk403716510/inactive/RTC_Developer-IEP_Trial.jar" could not be processed

I tried unzipping the .zip and adding the .jar file directly but it also says there are no valid keys in it.

I noticed that in the workshop: On the Run Configurations dialog, select JUnit2 Launch > [RTCExt] Create RTC Test Database and then click Run. It contains the test bundles that create the DB and the licenses. But then we launch Jetty from the Debug Configurations dialog. Is this correct?



Ralph Schoon commented Feb 21 '19, 6:12 a.m.
FORUM ADMINISTRATOR / FORUM MODERATOR / JAZZ DEVELOPER

Don, I have spent a whole lot of time in trying to make it clear what to run and how. To create the test database run a Junit^2 with [RTCExt] Create RTC Test Database.


Once that has succeeded debug an OSGI^2 Launch [RTCExt] Create RTC Test Database
 
But debug and run only makes a different in performance and if you have breakpoints set.

As far as I know the licenses you import into the workspace are important and you have one of two possible one. The launch files refer to both and should show one as missing. 


Ralph Schoon commented Feb 21 '19, 6:14 a.m.
FORUM ADMINISTRATOR / FORUM MODERATOR / JAZZ DEVELOPER

 I have never seen the error processing the licenses. Maybe consider  https://rsjazz.wordpress.com/2018/11/23/rtc-extensions-workshop-how-to-fix-ssl-protocol-errors-preventing-connection-to-jetty-debug-server/


I have no idea otherwise.


Don Cooper commented Feb 21 '19, 8:00 a.m. | edited Feb 21 '19, 8:01 a.m.

Thanks Ralph. The Jetty launch was using my local JRE which is 8.1. RTC 6.0.3 requires 7.1 which is what comes with the workshop development server so I pointed the Jetty launch to that and it's working.

Thanks for the help.

I also wanted to mention another issue I found. There are two subfolders -- apps and conf -- in the RTC603Dev\installs\JazzTeamServer\server\liberty\clmServerTemplate folder that should be copied to the RTC603Dev\installs\JazzTeamServer\server\liberty\servers\clm folder the first time you run the liberty server but the 'conf' folder did not get copied. I had to do it manually.

Thanks for your support.


Ralph Schoon commented Feb 21 '19, 8:17 a.m.
FORUM ADMINISTRATOR / FORUM MODERATOR / JAZZ DEVELOPER

 Thanks for the status update. The liberty issue: usually this happens automatically. Have not seen such an issue. Might be permission issues? 


Please accept the answer.

Your answer


Register or to post your answer.