It's all about the answers!

Ask a question

Trying to build custom work item type


Jozef de Vries (1131) | asked Nov 02 '09, 9:58 a.m.
JAZZ DEVELOPER
Hello,

I'm creating a custom work item type that consists of about 99% custom attributes, and i've run into a couple of issues:

1. Not all the tabs/attributes show in the eclipse client, but do show in the web client.
2. In the web client, when i have an open work item, task, defect, any type other than the new one, and then when I use the "type" pull down to switch to the new type I created, I get the following error
"TypeError: _1c is null"
When I dismiss that, nothing of the work item shows. Only when I use the "Create work item" pull down, and select the new work item type does it display correctly.
3. When I create new attributes, they display as inactive in pre-existing work items.
4. Can the discussion thread be pre-populated with content?

2 answers



permanent link
Marcel Bihr, Jazz Work Item team (1.4k) | answered Nov 03 '09, 2:57 a.m.
JAZZ DEVELOPER
Hi

1. Is there any pattern in which attributes are displayed and which aren't? If you have a scenario that does not work as expected, please open a work item filed against the Work Items category and attach the process specification source s.t. we can try to reproduce it.
2. Please open a defect filed against Work Items
3. This is expected behavior, see http://www-01.ibm.com/support/docview.wss?rs=3488&uid=swg21372230 for more information.
4. No, currently not. If this is important to you, feel free to file an enhancement work item and describe your scenario.


Regards

Marcel
Jazz Work Item team

permanent link
Jozef de Vries (1131) | answered Nov 03 '09, 9:01 a.m.
JAZZ DEVELOPER
Hi Marcel

1 & 2. Submitted work item 98269 and attached my process config.
3. worked like a charm.
4. Will re-evaluate the need for this and submit an enhancement if necessary

Thanks, this all helps.
Jozef




Hi

1. Is there any pattern in which attributes are displayed and which aren't? If you have a scenario that does not work as expected, please open a work item filed against the Work Items category and attach the process specification source s.t. we can try to reproduce it.
2. Please open a defect filed against Work Items
3. This is expected behavior, see http://www-01.ibm.com/support/docview.wss?rs=3488&uid=swg21372230 for more information.
4. No, currently not. If this is important to you, feel free to file an enhancement work item and describe your scenario.


Regards

Marcel
Jazz Work Item team

Your answer


Register or to post your answer.