It's all about the answers!

Ask a question

Build missing required license


Harry Koehnemann (30115138) | asked Oct 27 '09, 1:34 p.m.
I hope this is a simple one. I am having problems in RTC 2.0 getting builds to run due to licensing. The build engine is running on mu local machine as my user. That user has a developer license (I also tried adding a build license). I am a member of the team area and project and a checked project permissions and my role has all the build permission checked. I've tried a personal build using my workspace and a team build and all give the same error.

I had builds in 1.0.1 working fine but there appears to be some licensing changes in 2.0. Any help is greatly appreciated.


2009-10-27 10:22:13 running on host: harrypc
2009-10-27 10:22:13 Should build occur?
2009-10-27 10:22:13 Yes: Always build a user initiated request.
2009-10-27 10:22:14 Invoking pre-build participant "com.ibm.team.build.jazzscm"
Deleting fetch destination "D:\RTC2.0\client\jazz\buildsystem\buildengine\eclipse\sandbox" before fetching ...
Fetching files to fetch destination "D:\RTC2.0\client\jazz\buildsystem\buildengine\eclipse\sandbox" ...
2009-10-27 10:23:09 Invoking build participant "com.ibm.team.build.ant"
Buildfile: D:\RTC2.0\client\jazz\buildsystem\buildengine\eclipse\sandbox\releng\build.xml

fetchCodeAndBuild:
Unable to update last contact time for engine: 'Save Build Engine' failed. Missing required license.
com.ibm.team.process.common.advice.TeamOperationCanceledException: 'Save Build Engine' failed. Missing required license.
at com.ibm.team.process.internal.common.advice.runtime.OperationAdviceManager.createLicenseNotGrantedException(OperationAdviceManager.java:382)
at com.ibm.team.process.internal.common.util.AbstractProcess.doAdvise(AbstractProcess.java:173)
at com.ibm.team.process.internal.service.ServerProcess.access$1(ServerProcess.java:1)
at com.ibm.team.process.internal.service.ServerProcess$2.run(ServerProcess.java:130)
at com.ibm.team.repository.service.internal.TransactionService$1.run(TransactionService.java:99)
at com.ibm.team.repository.service.internal.rdb.RepositoryDatabase$Transaction.run(RepositoryDatabase.java:466)
at com.ibm.team.repository.service.internal.rdb.RepositoryDatabase$1.run(RepositoryDatabase.java:292)
<snip>
at org.apache.tools.ant.launch.Launcher.main(Launcher.java:104)
Name: Save Build Engine
ID: com.ibm.team.build.server.saveBuildEngine
Severity: ERROR
Summary: Missing required license
Description: The client access licenses assigned to the current user do not allow the "Save Build Engine" operation. Assign one of the following license types to this user to allow this operation: ClearCase Connector, Developer, Build System, ClearQuest Connector.
Severity: ERROR

BUILD FAILED
D:\RTC2.0\client\jazz\buildsystem\buildengine\eclipse\sandbox\releng\build.xml:38: com.ibm.team.process.common.advice.TeamOperationCanceledException: 'Save Build Result' failed. Missing required license.

Total time: 16 seconds
Build failed. Exit value was 1.

4 answers



permanent link
Harry Koehnemann (30115138) | answered Oct 29 '09, 1:57 p.m.
I did figure out the problem. The user/pass in the build.xml script did not have a license. Note that this is not the user/pass given to the jbe build engine. Hope this helps someone in the future.

permanent link
Ralph Schoon (56.7k23642) | answered Oct 28 '09, 4:20 a.m.
FORUM ADMINISTRATOR / FORUM MODERATOR / JAZZ DEVELOPER
Typically the build engine is run as a technical user e.g. "build". This user needs to have a build license. The user running a build delegates the work to that user and only requires a developer license to do so. The technical user Build needs to be member of the project and I'd check that this role is allowed to save and manipulate builds etc.

I guess if you want to run as a build user as well as a developer you'd need both licenses assigned to this user.

Just some thoughts,

Ralph

permanent link
Harry Koehnemann (30115138) | answered Oct 29 '09, 12:54 p.m.
Thanks for those comments Ralph. For some reason that fixed the problem, for all users. Strange. I added another user with only the Build System license, added to the project and the team, ran the engine w/ that user and it worked. But now it also works for my original user. Thanks for the help and I wish I could describe for others who might find this post what fixed the problem, but I can't.

permanent link
Ralph Schoon (56.7k23642) | answered Oct 30 '09, 12:53 p.m.
FORUM ADMINISTRATOR / FORUM MODERATOR / JAZZ DEVELOPER
Hi Harry,

great you found it.

I'd use the same technical user to run the build engine and the ant tasks in the build if possible. This user only needs the build license.

Ralph

Your answer


Register or to post your answer.