It's all about the answers!

Ask a question

Can someone provide me an example of logging into RTC using SCM with the smartcard option?


Bob Ferguson (8520) | asked Feb 11, 2:49 p.m.

I am using RTC 6.0.5 and we are required to use a smartcard/CAC when we login.

When I start the eclipse client and login, everything works great.

However when I try scm or lscm it does not.  The following is the command I enter:

lscm login -r https://happydays.are.here.mil/ccm -n GATOR -P smartcard

When I do I get the following response:

Problem running 'login':
--password cannot be used without --username or --certificate. Try 'lscm help login' for more information.

I do not know if the syntax is correct for using a smart card (e.g. the way  I selected to use smartcard). 

I do not know what to put in the command, both username and certificate require an argument.

I do not know what that argument would be. 

Could someone provide me an example of logging into a repository via scm/lscm using the smartcard option?

Accepted answer


permanent link
Ralph Schoon (54.3k13641) | answered Feb 12, 9:21 a.m.
FORUM ADMINISTRATOR / FORUM MODERATOR / JAZZ DEVELOPER
edited Feb 12, 9:22 a.m.

 This works for me 6.0.5.


lscm login -r "https://clm.example.com/ccm" --smartCard --username somebody

note it is --smartCard and not --smartcard . The help is consistent. I did not spot the capital C.

Bob Ferguson selected this answer as the correct answer

One other answer



permanent link
Ralph Schoon (54.3k13641) | answered Feb 12, 2:33 a.m.
FORUM ADMINISTRATOR / FORUM MODERATOR / JAZZ DEVELOPER
edited Feb 12, 9:21 a.m.

 I don't have a smartcard, but the documentation: https://jazz.net/help-dev/clm/index.jsp?re=1&topic=/com.ibm.team.scm.doc/topics/login.html&scope=null


states to use --smartCard and not smartCard. The option explanation for smartcard would be

--smartCard -u/--username <arg>


-P is a different writing for --password and is not used for smartcard. The documentation seems to indicate that you have to provide your user name. So you should try  

lscm login -r https://happydays.are.here.mil/ccm -n GATOR --smartCard -u <your user name>


Comments
Shashikant Padur commented Feb 12, 4:02 a.m.
JAZZ DEVELOPER

If I remember it correctly you need to provide the smart card alias to the -u option. You can find the aliases registered with the smart card by running 'lscm list smartcard-aliases'


Bob Ferguson commented Feb 12, 8:54 a.m.
 I tried to enter the command the way you suggested and I received the following error:
Argument syntax error:
Subcommand "login" does not support option "--smartcard". Try 'lscm help login' for more information.


Shashikant Padur commented Mar 26, 1:52 a.m.
JAZZ DEVELOPER

The error message is still showing the option as "--smartcard". It should be "--smartCard" (with a capital 'C'). Can you cut and paste your command here?

Your answer


Register or to post your answer.