It's all about the answers!

Ask a question

RTC 6 eclipse extention problem on eclipse 4.8 (photon)


Dan Nimick (2112) | asked Jul 19 '18, 8:04 p.m.
Eclipse 4.8 (photon) appears to be incompatible with RTC 6. With RTC Eclipse extension installed, Photon takes a long time to start (minutes), pegs CPU, and uses all memory allocated to Eclipse. If not enough memory is allocated (ex. 4GB), it will fail to start with a heap dump due to out of memory. If enough is allocated, it will start, but consume all of it. If 5GB is allocated, it will use all of that. If 15GB (!) is allocated, it will use all of that! I tried both 6.0.4 and 6.0.6 (which I can't really use since it's incompatible with our 6.0.4 server). If I uninstall it, Eclipse returns to normal startup behavior (a few seconds, increased but not pegged CPU, uses < 2GB of memory).

I didn't find this reported anywhere. Is it a know problem? Something particular with my installation? Any suggestions on how to fix it?

Thanks,
Dan

Comments
Geoffrey Clemm commented Jul 20 '18, 12:23 p.m.
FORUM ADMINISTRATOR / FORUM MODERATOR / JAZZ DEVELOPER

Do you have any other plug-ins loaded into your version of 4.8, or is RTC the only plug-in you have loaded?


Dan Nimick commented Jul 20 '18, 12:54 p.m.

Yes, many. Good point. When I get a chance I'll install a completely empty Photon and add RTC and see what happens. If that works, I'll add more until it breaks. If I had to bet, it would be WebSphere Liberty Server that might be interfering...

Accepted answer


permanent link
Dan Nimick (2112) | answered Jul 20 '18, 11:24 p.m.
So following up on Geoffrey's hint about other plugins I installed a new, clean copy of Photon, added only RTC, and it worked. I then added Liberty and it still worked. I then added all my usual plugins and it still worked.

So not sure what difference the plugin install order made, or if I somehow polluted the install in some other way, but it's perfectly happy now. Starts in just a few seconds using only about 1GB of memory, which is better than my previous install behaved even without RTC installed. Which probably indicates that there was something fundamentally wrong with it that RTC just pushed over the edge.

And FWIW, Ralph, I'm using Java EE, IBM Java 8, 64 bit, on Windows 10. And I agree that the first start takes some time and after that is fine. I've observed that behavior on pretty much every plugin install, not just RTC.

Thanks much Geoffrey and Ralph for your comments / help!
Ralph Schoon selected this answer as the correct answer

Comments
Ralph Schoon commented Jul 21 '18, 6:21 a.m. | edited Jul 21 '18, 6:21 a.m.
FORUM ADMINISTRATOR / FORUM MODERATOR / JAZZ DEVELOPER
Eclipse parses the new plugins on startup to add it to a cache to make later starts faster.
You will notice the difference if you clean Eclipse using the -clean option.

2 other answers



permanent link
Sunil Kumar R (1.1k12143) | answered Jul 20 '18, 1:41 a.m.
JAZZ DEVELOPER

Correct. Eclipse v4.8 is incompatible with RTC v6.0. Here is a snapshot showing supported versions of eclipse.


You can get to this from :
https://jazz.net/wiki/bin/view/Deployment/CLMSystemRequirements > click on link for CLM version > RTC > Prerequisites > Eclipse Runtime environment.

Even the latest release of RTC (CLM) as of today (v6.0.6) does not support eclipse version v4.8.

It would be good to use one of the supported eclipse versions.


Comments
Dan Nimick commented Jul 20 '18, 7:05 a.m.
Sunil,

That screenshot is less than useful. At first glance it made me think RTC hasn't been supported on Eclipse for the last 4 versions (since 4.4)! Perhaps you just read my title, and not my comment, which specifically says I'm using 6.0.4. Anyway, I went to the site you posted and see that 6.0.4 says that the highest supported Eclipse version is 4.6, but I know for a fact that it works fine on 4.7, because that's what I was using prior to updating to 4.8 (I admit I failed to mention that in my comment). Also, the highest RTC version listed on that site is 6.0.5 (which does say Eclipse 4.7 is supported). Where is the listing for 6.0.6 (not that it really matters, I believe you that it won't say that Eclipse 4.8 is supported).

Bottom line is the RTC has worked fine on "unsupported" versions of Eclipse for a long time. It's unreasonable to expect developers to stay on a particular version of Eclipse just because the RTC site says it's not supported. Developers will always try the newest Eclipse as soon as it comes out, and up until now, RTC has always worked for me.

permanent link
Ralph Schoon (56.5k23642) | answered Jul 20 '18, 3:07 a.m.
FORUM ADMINISTRATOR / FORUM MODERATOR / JAZZ DEVELOPER
edited Jul 20 '18, 3:23 a.m.

I set up an RTC 6.0.6 Extensions workshop with Eclipse 4.8 (photon) on Windows and that seems to be work fine.
I used the P2 install as explained in the Extensions workshop.


Comments
Dan Nimick commented Jul 20 '18, 7:34 a.m.
Thanks Ralph,

I'm using a p2 install as well. Specifically this file
RTC-Client-p2Repo-6.0.4.zip
from here
https://jazz.net/downloads/rational-team-concert/releases/6.0.4?p=allDownloads
(the "p2 Install Repository" link on that page)

Did you get yours from somewhere else?

Ralph Schoon commented Jul 20 '18, 7:50 a.m.
FORUM ADMINISTRATOR / FORUM MODERATOR / JAZZ DEVELOPER

I use the P2 from all downloads. I have only started to test Photon (Eclipse 4.8?) with 6.0.6. I think I ran the 6.0.4 on Luna back then.
I just tested with the 6.0.4 P2 and I can not reproduce your problem. Photon with 6.0.4 seems to work fine for me. The first start takes more time, but after that it works great so far.

Note I used the downloads for Java/plugin developer (not EE).
Note I used Java 8 and I have all 64 bit versions.

I have seen that newer Eclipse versions showed up in later version in RCT 4.x and 5.x.

Not sure if this is helpful.

Your answer


Register or to post your answer.