It's all about the answers!

Ask a question

Issue with DNG Workflow


Mahari Hill (484177195) | asked Mar 20 '18, 8:00 p.m.

CLM 602

I have 100 artifacts of Requirement type. I created a new state workflow and applied it to this artifact type. Anything new I create gets the first state(Draft). I can migrate to the other states fine:

Draft
Review
Approved

A user imported 20 of this artifact w/o the state. So now I have a total of 125 artifacts in which 5 newly created are in the Draft state, and 120 are empty. My problem is that the others only list Review and Approved as states to migrate to. I have no initial state of Draft.

Is this a defect?

One answer



permanent link
Donald Nong (14.4k313) | answered Mar 20 '18, 9:06 p.m.

I just tried it with DNG 6.0.2 iFix006 and all artifacts got the initial workflow state right after I applied a workflow to an artifact type. I believe this should be the expected behavior. Unless there is another action besides the "start action" with target state as the initial state, you will not be able to use the "Change State" action to bring it back to an initial state.


Comments
Mahari Hill commented Mar 21 '18, 8:31 a.m.

Hello and thanks for responding.

I went in to our new 605 testing environment and created a new LPA. I applied the "Sample Workflow" to a artifact type and the same thing happened. The 8 artifacts that were there before the update are empty in the state workflow and you have to move all of the work items to the Draft state.

I'm not sure how you were able to get it to work, but in our two environments, it seems to work this way. For documentation i'm going to need to do a PMR.

thanks for the help.

Your answer


Register or to post your answer.