It's all about the answers!

Ask a question

Query for work items with square brackets in the summary


Marie Michelin (149) | asked Mar 05 '18, 6:09 a.m.

Hi everyone,

We have a lot of work items starting with square brackets that we would like to find with a query.
But when we try to execute the query "summary start with [" the result is empty.
We tried with the web client, Eclipse client and also with the Plain Java API.
It is still the same issue.

We tried using the hexa code (\u005b) or the ASCII code ([) but it is still not working.

Trying to find escape character, but without success.

I'm running out of ideas ...

Is it possible ? What is the way to do that without querying all the work items in Plain Java API and then filtering it ?

(We're using RTC 6.0.2)

Thanks for your help,

2 answers



permanent link
Donald Nong (14.4k313) | answered Mar 06 '18, 7:38 p.m.

Interesting. It works for me with RTC 6.0.2 iFix006. In fact, both "Summary starts with [" and "Summary ends with ]" work for me.


permanent link
Marie Michelin (149) | answered Mar 07 '18, 5:14 a.m.

That's really surprising ...
I looked at the log file in the Eclipse workspace, and there is no error.

We are using the iFix 015. But we have also on server for tests that is still with the iFix 012 and another old one with RTC 5.0.2, and both have the same behavior ...

I made some other tests with my RTC 6.0.2 iFix 015.
- If I run a query with "summary ends with ]", the result is ok
- If I run a query with "summary contains [", I get no result
- If I run a query with "summary contains ]", the result is ok

So the problem is only with the opening square bracket, it seems.


Comments
Matt Muller commented Mar 07 '18, 6:50 a.m. | edited Mar 07 '18, 6:54 a.m.

Marie,

I've tested in 6.0.4 ifix 005 and get the same result for "Summary contains" =  "[" no results.  "]" result is ok

I assume this is a bug.

Seems to work in 6.0.6 M3


Marie Michelin commented Mar 07 '18, 12:13 p.m.

Thanks Matt for testing in other versions.
We didn't plan to move to 6.0.6 soon, so as it is not a big issue, we'll let it in this state.

I'm just surprised that Donald see it working well in 6.0.2.

Whatever, as I said it is not a big issue, so don't worry.
Thank you !

Your answer


Register or to post your answer.