It's all about the answers!

Ask a question

LQE does not get updated when adding/removing links between RTC work items


0
1
Jürgen Brückler (698) | asked Jan 23 '18, 2:01 a.m.

We use RTC 6.0.5 with several custom linktypes between work items.
LQE Reports show correct values about RTC work item attributes.
But if a link between 2 work items was added or removed, LQE still shows the old data (without/with the link that was added/removed).
After saving one of these 2 linked work items the links in LQE become updated and the report is up to date again.


In RTC you do not have to save the work item if you just want to add/remove a link (a common use case in our organization), so this difference between "real" data and report data is quite a problem for us.

We have the following LQE data sources installed:
TRS 2.0 for RTC Resources
TRS 2.0 for RTC Process Resources
TRS 2.0 for Link Validity Resources
...

How can we update LQE on link changes between work items automatically?

Thanks,
Juergen


Comments
Ralph Schoon commented Jan 23 '18, 7:06 a.m.
FORUM ADMINISTRATOR / FORUM MODERATOR / JAZZ DEVELOPER

I am sorry, but I don't understand

"In RTC you do not have to save the work item if you just want to add/remove a link (a common use case in our organization), so this difference between "real" data and report data is quite a problem for us."



Removing a link is a change to a work item and I am unsure how you would be able to remove a link between work items without at least saving one of the work items.

Can you clarify what you are doing and how?


Jürgen Brückler commented Jan 23 '18, 8:33 a.m.

 Ralph, yes, you are correct. I did remember this wrong.

You have to save the work item after adding/removing a link.
But this save action does not get synchronized with LQE.
As soon as I update an attribute of this work item (e.g. a string attribute) the links will become updated in LQE.


Ralph Schoon commented Jan 23 '18, 8:40 a.m. | edited Jan 23 '18, 9:40 a.m.
FORUM ADMINISTRATOR / FORUM MODERATOR / JAZZ DEVELOPER

Jürgen, I would suggest to create an PMR or ER for this if it does not work for you.
I don't know if it should work the way you expect but I would agree I would expect it to do.


Don Yang commented Jan 31 '18, 12:30 a.m. | edited Jan 31 '18, 12:36 a.m.

Juergen, LQE index/refresh runs at x min(1min or 3min or 5min I can't remember exactly) interval hence it looks normal to me that after a little while you can 'see' the link in the LQE as index was run. It is near real time but not exactly real time events.

Be the first one to answer this question!


Register or to post your answer.