It's all about the answers!

Ask a question

How to install EGit plugin - Git Integration for Eclipse?


Louis Lock (3016) | asked Dec 08 '17, 12:20 p.m.

I tried to install the EGit plugin for Eclipse 4.6.0 but failed and got an error while the installation was collecting items to be installed.  Please see the attached snapshot for the error details.  I've tried the installation from the Help->Eclipse Marketplace and Help->Install New Software.  Both ended up the same failure.  Any help?  Thanks.

Error message:
An error occurred while collecting items to be installed
session context was:(profile=IBM Software Delivery Platform com.ibm.sdp.eclipse.ide, phase=org.eclipse.equinox.internal.p2.engine.phases.Collect, operand=, action=).
No repository found containing: osgi.bundle,com.ibm.rational.clearcase.ccrefresh,7.6.2.v201301111453

Accepted answer


permanent link
Donald Nong (14.4k314) | answered Dec 19 '17, 12:32 a.m.

This post addresses a very similar issue. Maybe you can give it a try?
https://www.ibm.com/developerworks/community/forums/html/topic?id=3b0e52bc-b366-45c5-a036-20c4ed800e27

Louis Lock selected this answer as the correct answer

Comments
Louis Lock commented Feb 13 '18, 1:54 p.m.

Hi Donald, sorry for a late response as I have been distracted by some other priorities :).  Finally, I was able to try your workaround solution.  Yes, it worked for me and I was able to install the EGit plugin on my Eclipse Client.  Thanks.

One other answer



permanent link
Ulf Arne Bister (1.3k11) | answered Dec 17 '17, 2:44 a.m.

 You failed to mention into what Eclipse (Rational Team Concert Eclipse Client? Rational Developer for System i Eclipse Client?) you are trying to install the plugin. That might play a role.


Looking at the error message it was resolved in a similar situation by starting the Eclipse with administrative priviledges. Does it work if you do that?

- Arne

Your answer


Register or to post your answer.