It's all about the answers!

Ask a question

Unexpected behavior with mail notifications.


Brian Thompson (41184) | asked Sep 23 '09, 12:09 p.m.
The complaint I received from the users was that mail notifications were not being received when work items were created.

After some experimentation it has so far come down to this:

PM created a Work Item and neither he nor the assigned owner received an email. The default mail configurations were in place.

Note that by default the following boxes are checked:
Creator / work item was created or reopened.
Owner / work item was created or reopened.
so everyone expected emails to be generated and they were not.

The following were tried, to no avail:
1) add check mark on Creator / subscriber added or removed.
2) add check mark on Creator / owner started or stopped work on a Work Item

Nextly was tried
3) add check mark on Modifier / work item was created or reopened

And in this case (where the creator and owner were the same) an email was generated.

The expectation is that if Any of the conditions is true then an email is sent. If nothing else, the current behavior seems rather unintuitive.

We are running Rational Team Concert 2.0 I20090618-1753.
Should it matter, the work item type was Task, the template is OpenUP.

I'd ask the PM to run some more tests but he's losing patience.

The work-around is of course telling everyone to do a 'Select All' on the mail configuration panel and keep it that way; Unfortunately other team members are unhappy because 'there are too many emails generated'.

Any suggestions would be appreciated.

One answer



permanent link
Work Item & UI Commons Team (1.3k1) | answered Sep 24 '09, 8:16 a.m.
bltjazz wrote:
The complaint I received from the users was that mail notifications
were not being received when work items were created.

After some experimentation it has so far come down to this:

PM created a Work Item and neither he nor the assigned owner received
an email. The default mail configurations were in place.

Note that by default the following boxes are checked:
Creator / work item was created or reopened.
Owner / work item was created or reopened.
so everyone expected emails to be generated and they were not.

The following were tried, to no avail:
1) add check mark on Creator / subscriber added or removed.
2) add check mark on Creator / owner started or stopped work on a Work
Item

Nextly was tried
3) add check mark on Modifier / work item was created or reopened

And in this case (where the creator and owner were the same) an email
was generated.

The expectation is that if Any of the conditions is true then an email
is sent. If nothing else, the current behavior seems rather
unintuitive.

We are running Rational Team Concert 2.0 I20090618-1753.
Should it matter, the work item type was Task, the template is
OpenUP.

I'd ask the PM to run some more tests but he's losing patience.

The work-around is of course telling everyone to do a 'Select All' on
the mail configuration panel and keep it that way; Unfortunately
other team members are unhappy because 'there are too many emails
generated'.

Any suggestions would be appreciated.


In the case of creating a work item, the "Modifier" role has a stronger
weight compared to the "Creator" role. As soon as you enable to receive
a mail for created work items where you are the modifier, this case will
work. I can see that its confusing to do so, and will open a work item
on this particular case.

Still, the owner of a work item should receive an e-mail. I was unable
to reproduce this case locally, here is what I did:

Markus: Has Default Mail Settings
Bill: Creates a new Work Item and sets Markus as Owner

Markus receives an E-Mail as expected.

Can you look into the logs on the server if something is going wrong?

--
Benjamin Pasero
Work Item & UI Commons Team

Your answer


Register or to post your answer.