It's all about the answers!

Ask a question

The work item is visible in eclipse client but it is giving Error CRJAZ0215E in the web client and it is not loading up, Any advise.


0
1
sasi davuluru (132) | asked Jun 22 '17, 9:26 a.m.

 Hi 


We are on RTC version 6.0. Few work items for a user are visible and loading up in eclipse client but it is showing error and not loading the work item in the web client. I checked a post http://www-01.ibm.com/support/docview.wss?uid=swg21671560 and it says the error is with respect to the subscribers list. So I have removed the subscribed from the work item using eclipse client and added them back but didnt work, the error still pertains. Any ideas, Please advice. Thank you

PS: Here is the error message

Error!

Error fetching or storing Work Item XXXX | Details: Error opening work item. CRJAZ0215E The following record was not found in the database: com.ibm.team.repository.common.model.impl.ContributorHandleImpl@ab7b4e29 (stateId: <unset>, itemId: [UUID _SUuxgBygEeSe8cUURVNy_w], origin: null, immutable: <unset>)

2 answers



permanent link
Ian Wark (7142942) | answered Jun 23 '17, 1:29 a.m.

I think you are on to a likely cause. But it's possible that deleting in Eclipse is not enough. Check using the RESTClient first as per the suggested: http://www-01.ibm.com/support/docview.wss?uid=swg21671560. There is another user who tried this with the RESTClient however, and was not able to resolve it using the RESTClient. They mentioned that they used the Plain Java API to list and remove all subscriptions and that resolved the problem. I don't have a sample for that, but here is a link that might help to get started.

Rational Team Concert Plain Java APIs
https://jazz.net/library/article/1229.

You can find a lot of code samples here on the jazz.forum. HTH.


permanent link
sasi davuluru (132) | answered Jun 27 '17, 1:13 p.m.

 Thank you Ian for the reply. I tried the RESTClient it didnt work for me too. I tried the Link for the Plain Java APIs but I see it is not working anymore. Can you provide me an alternative link pls.


Thanks

Sasi-


Comments
Ian Wark commented Jun 28 '17, 2:43 a.m.

Please remove the dot at the end of the URL. It still works.

Your answer


Register or to post your answer.