It's all about the answers!

Ask a question

lscm not work under windows


Artur Friedrich (111) | asked Apr 12 '17, 2:12 p.m.

Hello, by me on windows 10 64 bit only work scm. If I try it with lscm it locked by a command a file and not give it free. if the next lscm will be executed it say process already locked.

I have tried all but nothing help. I am only know that with scm daemon stop --all I can unlocked it.

Can somebody help that it work with lscm too.

Thanks

Artur

3 answers



permanent link
Donald Nong (14.4k314) | answered Apr 12 '17, 10:39 p.m.

You should learn the differences between the scm and lscm command (the second Note in the below document).
https://jazz.net/help-dev/clm/topic/com.ibm.team.scm.doc/topics/c_scm_cli.html

I believe the lock file is basically an indicator of the running daemon.


permanent link
Shashikant Padur (4.2k27) | answered Apr 12 '17, 11:10 p.m.
JAZZ DEVELOPER
The way 'lscm' works is that for sandbox related operations such as check-in and status it will try to lock the sandbox before performing the operation. If the sandbox lock is held by some other 'lscm' daemon or RTC Eclipse client process then it will throw an error informing that the sandbox is locked. 
You can run 'scm list daemon' to see the sandboxes locked by the scm processes.

So the issue could be that the first 'lscm' command run would have locked the sandbox and you running another 'lscm' command outside of the sandbox launches a separate daemon process and tries to lock the same sandbox.
You should run the second 'lscm' command either from within the sandbox or you could specify the -d/--directory option to the command and provide value as the path to the sandbox.

This issue will not occur for a remote operation such as listing a workspace or listing files of a repository workspace as it does not deal with the sandbox.

Comments
Artur Friedrich commented Apr 13 '17, 1:44 a.m. | edited Apr 13 '17, 5:30 a.m.
 Thanks, but I am standing in the sandbox, and I am adding the --directory to every command and it not worked
Here my steps
changing to my sandbox
cd c:/Users/mm/workspace_rtc_6_2/
create changeset
lscm create changeset "mycomment" -w myworkspace --component mycomponent -r nick  --directory c:/Users/mm/workspace_rtc_6_2/
create property
 lscm set property a5144155-a584-4dcc-b2df-50e6cac4e826 0 mysourcetree\myfile.txt -r nick --directory c:/Users/mm/workspace_rtc_6_2/
And now I get he exception
Could not lock C:\Users\mm\workspace_rtc_6_2 - locked by other process
With scm it work only with lscm not work. I used rtc-6.01
How it seems that the "changeset" command generate the in lockfile workspace_rtc_6_2\.jazz5\.jazzlock and give after the execution the command not free.
And if I try to set the property i get the "..locked by other process" exception.
Why do after execute "changeset" not give .jazzlock free?
Only one daemon Prozess is running
scm list daemons
Port  Beschreibung
53971 Jazz-Befehlszeilenschnittstelle (3.2.600.v20151029_0226)
C:\Users\mm\workspace_rtc_6_2
Any Suggestion?

Shashikant Padur commented Apr 13 '17, 4:25 a.m. | edited Apr 13 '17, 4:28 a.m.
JAZZ DEVELOPER

The above steps should have worked. I tried it in my environment and am not able to reproduce this issue.

As a side note: You do not have to specify --directory option if you are already in the sandbox.


Artur Friedrich commented Apr 13 '17, 4:36 a.m.
 Can you say in which environment you testet.
Here is my
RTC-CLIENT-VERSION=6.01 (Client and Server. (I used the scmtools inside the client)
OS=WINDOWS 10, 64 BIT (Windows Home Edition)
Have you modified scm.ini or lscm.bat ?

permanent link
K P (211) | answered Jun 02, 8:20 a.m.

If I am hitting the commands from root directory and I have created one folder as a sandbox in different location. I want to load the stream data at that location so what will be the command. Please guide


Comments
Shashikant Padur commented Jun 02, 11:52 p.m.
JAZZ DEVELOPER

To load into a directory other than the current working directory use the -d/--directory command. Please provide more details with examples as if this is not what you are looking for.  

Your answer


Register or to post your answer.