It's all about the answers!

Ask a question

cannot build


francesco viscomi (514) | asked Jan 21, 4:41 a.m.
Hi all II'm new to  rational-team-concert,
I've tried for the first time to make  a build but the RTC complains that 


Invoking pre-build participant "com.ibm.team.build.jazzscm"
com.ibm.team.build.common.TeamBuildException: CRRTC3529E: The user, buildUser, does not have read access to the workspace with the following UUID: _e0TgAEUAEeuN3PwLqSx.



I 've tried to google at it and find


but there is not indication about to do that, and also the link indicated do not bring me to any useful information.

I'm using Rational Team Concert
Version: 6.0.2
Build id: RTC-CLIENT-I20160323-2215

can some one give me some advice to solve the issue?
thanks

One answer



permanent link
Ralph Schoon (58.0k23642) | answered Jan 21, 10:43 a.m.
FORUM ADMINISTRATOR / FORUM MODERATOR / JAZZ DEVELOPER
edited Jan 21, 10:53 a.m.
The error message says that the user 'buildUser' has no read access to the workspace in that build. Check the ownership of the workspace and the visibility settings.

A build user needs read access to the project area (Access Control), and the build user needs to have at least read access to a repository workspace (for private builds).

For normal builds the build user should be owner of the build repository workspace.

In general for repository workspaces that are not owned by the build user, the build user has to be able to read them, so they can't be private. The selected ownership and visibility scope must be accessible for the build user.

Login as the build user (Eclipse client or Web UI) and try to read the workspace in question using that user. Make sure you can read and consider the ownership and visibility settings.

If you can read it I don't know and would suggest to contact support.

Comments
francesco viscomi commented Jan 21, 1:24 p.m.

Thanks for the answer, indeed with the user i log in in eclipse client i can read/write everithing in the path where the workspace is located. 


Ralph Schoon commented Jan 21, 2:17 p.m. | edited Jan 21, 2:19 p.m.
FORUM ADMINISTRATOR / FORUM MODERATOR / JAZZ DEVELOPER
This comment does make absolutely no sense. We might speak about two  different places in the multiverse.

If you ruser can load the repository workspace, the error message does not make sense. There is also pretty much no information in the question. Support might be better suited to get the necessary information.

Your answer


Register or to post your answer.