It's all about the answers!

Ask a question

error run JTSMon

Joao Ramires (34319) | asked Apr 04 '17, 5:56 a.m.

 Hi all.. I'm starting to play with JTSMon. When I use the option "analyze" I get this error: 

C:\LocalAPP\JazzMon>C:\LocalAPP\IBMRTCz502\jdk\jre\bin\java -jar JTSMon.jar analyze
SharedNetworkDirectoryWindows: c:\temp\JTSMonData
SharedNetworkDirectoryLinux: /var/tmp/RPP_GatherData
SharedNetworkDirectory(local): C:\LocalAPP\JazzMon\JTSMonRuntime
Output Subdirectory: C:\LocalAPP\JazzMon\JTSMonRuntime

Will analyze monitor output directly because ANALYSIS_IN_PLACE is true
        using C:\LocalAPP\JazzMon\JTSMonRuntime
Searching for counters in C:\LocalAPP\JazzMon\JTSMonRuntime
Found counter directory C:\LocalAPP\JazzMon\JTSMonRuntime\jts-prod.ccm
Found counter directory C:\LocalAPP\JazzMon\JTSMonRuntime\jts-prod.jts
Picked counter directory C:\LocalAPP\JazzMon\JTSMonRuntime\jts-prod.ccm
Detected ServerMonDir in JTSMonRuntime
Processing Server Tables: C:\LocalAPP\JazzMon\JTSMonRuntime
Custom baseline selected for jts-prod.ccm
        is C:\LocalAPP\JazzMon\Data\JazzDev_5.0.2GA_141124200users_8hrs\jazz.ccm200users_8hrs.txt
Directory: jts-prod.ccm
         using baseline file: C:\LocalAPP\JazzMon\Data\JazzDev_5.0.2GA_141124200users_8hrs\jazz.ccm200users_8hrs.txt
Processing service jts-prod.ccm etAvg 2017.04.04_10.46.20.103
Exception: Array index out of range: 2
java.lang.ArrayIndexOutOfBoundsException: Array index out of range: 2
        at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
        at sun.reflect.NativeMethodAccessorImpl.invoke(
        at sun.reflect.DelegatingMethodAccessorImpl.invoke(
        at java.lang.reflect.Method.invoke(
        at org.eclipse.jdt.internal.jarinjarloader.JarRsrcLoader.main(

Any suggestions? 


Accepted answer

permanent link
Robby Berner (261) | answered Apr 26 '17, 1:37 a.m.

It also works when using the follwoing command:
java -Duser.language=en -Duser.region=US -Dfile.encoding=UTF-8 -Dclient.encoding.override=UTF-8 -jar JTSMon.jar analyze

Important are the user.region and user.language options.

Joao Ramires selected this answer as the correct answer

Joao Ramires commented Nov 09 '17, 6:38 a.m. | edited Nov 09 '17, 6:39 a.m.

thanks , this was the solution:

java -Duser.language=en -Duser.region=US -jar JTSMon.jar analyze


2 other answers

permanent link
Robby Berner (261) | answered Apr 20 '17, 5:00 a.m.

I have the same problem.  I tried to  reduce the data range by using
ANALYSIS_DATA_RANGE=1,max_number_of samples 
in file

However,  jtsmon always throws an execption with  max_number_of samples +1

permanent link
Robby Berner (261) | answered Apr 25 '17, 7:51 a.m.

Hello Joao,

I could solve the problem.
For Windows PC: Under Control Panel -> Region and Language
I changed : Format and Location  to English
Then i worked for me.

I will do an additonal test in a cmd window by specifying  for example:
java -jar jtsmon.jar analyze -Duser.language=en_us ...

Your answer

Register or to post your answer.