It's all about the answers!

Ask a question

RTC and GIT Integration: a strange error code returns clicking on Commit Detail


0
1
Alberto Teodoro (6631734) | asked Mar 10 '17, 5:06 a.m.
Hi all,
I have integrated a GIT Server with RTC (6.0.2) using Nodejs.
The integration seems to work fine, but I receive a strange Error message, with an unknown error code, when I click on the Commit detail: "CRRTC8810E: The Rational Team Concert server cannot connect to the registered Git repository."

What, the Commit dettail, should show me? Maybe, I've thought, I should have configured the Git Web?
GIT Commit detail
Many thanks in advance
Alberto


2 answers



permanent link
Shubjit Naik (1.4k1613) | answered Mar 10 '17, 5:17 a.m.

Hi Alberto


A few points on this, please ignore the ones that don't apply to you.

- To be able to view commit details, the NodeJS server needs to be running.
- RTC Server (VM/Server hosting RTC) should be able to connect to the NodeJS server 
- Under Registered Git Repository> Settings and make sure the Git User Details are entered.

Adding the article here in case you have not checked already.

Best Regards
Shubjit


Comments
Alberto Teodoro commented Mar 10 '17, 5:49 a.m. | edited Mar 10 '17, 7:11 a.m.
Hi Shubjit,
I have followed all instructions in the wiki, the Nodejs is running and, I believe, RTC Server is able to connect to the NodeJS server, otherwise, I was not able to link the Commit to my WI by GIT.
and I have  entered.
Instead, under "Registered Git Repository> Settings" I didn't set the Git User Details because the authentication is done by LDAP and the GIT users are that ones in my RTC Project Area.
I've to fill anyway the Git User Details? Who is the Git User if I use the user, with the appropriate GIT role, of my Project Area?

Man y thanks
ciao
Alberto

permanent link
Ton van Velzen (2642) | answered Mar 21 '18, 1:29 p.m.

Strange indeed, I run into the same error when opening the change set from the workitemś link page. Using RTC 6.0.5 iFix001, node v9.7.1, git 2.16.2 on RedHat 7.4. When I save the Git Repo Connection under RTC's Source Control, the same error message appears at the top of the screen in yellow.
Alberto, did you open a PMR/Service Request with Support? If not, I will do it.
Best wishes, Ton

Your answer


Register or to post your answer.