It's all about the answers!

Ask a question

Git Integration: Error occurred when fetching commit summary for commit id xxxx


Christine Makasy (73722) | asked Mar 09 '17, 8:14 a.m.

With RTC 6.0.2 I did the GIT integration nearly successfully.
I'm able to push a commit and create a link to the mentioned work item.

But there is still an open issue: In RTC navigating to the linked git commit results in the following error:
Error occurred when fetching commit summary for commit id xxxxx

I'm using GIT version 2.9.3 on Linux 16.10 together with RTC 6.0.2.

Many thanks in advance for your support.
Christine

One answer



permanent link
Shubjit Naik (1.5k1613) | answered Mar 09 '17, 9:32 a.m.
edited Mar 09 '17, 9:39 a.m.

Hi Christine


Have you integrated RTC with Git hosted on NodeJS server?
Or are you using any existing Git Server like GitLab, GitHub, Gerrit?

The Git commit URL is formed based on the Commit URL entered in "Commit URI Format" under 
Source Control> Registered Git Repository > [Name] > Settings ,  in RTC.

For NodeJs, we use
$repo/commit/$sha1

where in $repo is replaced by the Git Repository URL as mentioned while registering
And,  $sha1 is replaced by the commit hash id

Best Regards
Shubjit


Comments
Christine Makasy commented Mar 09 '17, 10:57 a.m.

 Hi Shubjit,


trying your hint I get the following error message:
You don't have permission to access /myProject.git/commit/6a23c53b29c726f8f9a764553f46e68f2f06d192 on this server.
Below my Git Repository I don't find a structure like mentioned above. 

Do you have a solution for this. Many thanks.

kind regards,
Christine


Shubjit Naik commented Mar 09 '17, 10:52 p.m. | edited Mar 09 '17, 10:53 p.m.

 Could you try this?

Find out your Commit URL on your Git server and update the base URL in Commit URI Format.
Example: http://gitserver:port/git/Myproject.git/commit/$sha1
$sha1 would be replaced by the commit hash id


Shubjit Naik commented Mar 10 '17, 5:25 a.m. | edited Mar 10 '17, 5:28 a.m.

Additional Please check if the user details entered Under Registered Git Repository> Settings are correct.

If these details are missing, you might get permission errors.

In case you are using Nodejsto host Git repositories, please remove the value from Commit URL Format and check the option " Fallback to the process ...."

Your answer


Register or to post your answer.