It's all about the answers!

Ask a question

How to resolve file paths using "lscm list changes"


Matteo Vettosi (111) | asked Jan 25 '17, 3:35 a.m.

 We precedently had a script that starting from a work item, extracted all the modified files in it which were checked-in in some personal workspace, along with their full path... It worked gracefully until few days ago, when it simply started to only get <unresolved> paths.

In particoular, an example of the command we use is:
lscm list changes -r RTC -j -w 'mvettosi on tws_dev' _-9XOEMeQEea6C4MWzITOoQ

Of course, the workspace name is recognized and matched, and same behaviour occurs using uuid instead of alias.
We contacted our RTC server administration to get help but they assured that nothing at all has been done to the server from last time the command worked, to the first time it did not resolve paths anymore.

From eclipse client, everything works like normal: even from a completely different local workspace, it is possible to retrieve the full path of the change in the example above by selecting the 'mvettosi on tws_dev' workspace in the list. Only lscm stopped to do that, and has the same problem on three different environments (one linux, 2 windows).

Has anyone any clue about what is going on? Could be any user error, or what should we search on the server side?
Thank you in advance,
Matteo

One answer



permanent link
Bernd van Oostrum (21724357) | answered Jan 25 '17, 8:05 a.m.

 Hi,


You need to load the workspace somewhere. After that, you can execute "scm list changes" in combination with your workspace/stream + the path where you loaded it to (option -d <directory>).

Regards,
Bernd.


Comments
Matteo Vettosi commented Jan 25 '17, 9:16 a.m.

 On the Eclipse Client, it is possible to resolve the full path of a change whose workspace is not loaded, just selecting it from the list.
Likewise, with this script I was able to resolve paths using the -w "workspace alias" option, like it should be. The problem is that it stopped doing that, and we would like to understand why and how to fix this

Your answer


Register or to post your answer.