It's all about the answers!

Ask a question

Cannot populate custome attributes in DOORS NG 6.0.2


Scott Ankrum (25313) | asked Jan 13 '17, 2:26 p.m.

I am trying to learn to use DOORS Next gen 6.0.2, which is installed at the site where I work.  I need to create custom attributes for the text requirements.  I have successfully created several custom attributes, but I cannot populate any of them. 

 

I uploaded a short list from a spreadsheet, with the columns in the same order as the attributes.  Only the standard attributes were populated. 

 

So, I tried to edit a row, but none of the custom attributes responds to edit.

 

What am I missing?


Comments
Donald Nong commented Jan 16 '17, 12:15 a.m.

The order of the attributes should not matter. It's more about the name/ID. What exactly did you try?

Accepted answer


permanent link
Michael Reed (126415) | answered Jan 18 '17, 10:58 a.m.

Hi Scott,


I don't mean to sound condescending at all but here is the process I generally tell classes and customers so please take it as just my attempt at making sure you followed all the steps for making your attribute available to the Artifact Types you expect to see them in.

The general flow for custom attributes is this:
  1. Create a new or reuse an Attribute Data Type
    • This is the source of the data that will be used
  2. Create Artifact Attributes and reference the appropriate Attribute Data Type previously created if not reusing an existing type.
    • This make the attribute available to be used by Artifact Types but does not implicitly add them
  3. Select the Artifact Type (if you are not creating a new one) that you would like to add the new attribute to
    • In the properties of the Artifact Type you will see a list of Artifact Attributes and their associated Data Type.
    • Select Add Attribute --> find the attribute you created --> check it --> and save
    • Select the newly added attribute and move it up or down as needed and then Save the Artifact Type.
  4. You will need to refresh your browser window if you are looking at a different tab to see the results but the artifact should now contain the attribute on the right hand side. Be sure to select the correct Artifact Type and view any existing artifact or create a new one to see them.
I hope that is of some help and that you aren't running into some other issues. Please let us know.

Regards,

-michael

Scott Ankrum selected this answer as the correct answer

3 other answers



permanent link
Adrian Haw (264641) | answered Jan 17 '17, 8:05 a.m.

Are your user-defined attributes associated with artifact types?


permanent link
Scott Ankrum (25313) | answered Jan 18 '17, 10:39 a.m.

Thank you for the responses.  I followed the instructions at http://www.ibm.com/support/knowledgecenter/en/SSR27Q_6.0.3/com.ibm.rational.rrm.help.doc/topics/t_create_attribute.html

I didn't see anything in the instructions about associating a custom attribute with an artifact type.  I have several artifacts of type "Information" in the same module.  When I display the artifacts in that module, each of my custom artifact types is given a column with that artifact type as the column heading.  But, there is nothing in any of the rows for those columns and the cells do not display the pencil edit option when I hover the mouse over them.  I can edit the standard attributes.

Is there another step that associates a custom attribute with an artifact type?


permanent link
Scott Ankrum (25313) | answered Jan 18 '17, 1:15 p.m.

Michael,

Good information is never condescending.  Thank you.  I was able to upload values for my custom attributes, and they show as editable. 

Your answer


Register or to post your answer.