It's all about the answers!

Ask a question

Configuring CLM with Squid Cache proxy server


0
1
nicky john (315) | asked Nov 17 '16, 2:03 p.m.
edited Nov 23 '16, 3:58 p.m. by David Lafreniere (4.6k7)
 Hi All,

I am trying to configure RTC with Squid Cache proxy server. I have followed all the instruction's provided in https://jazz.net/wiki/bin/view/Main/SCMWithCachingProxy.

But while testing the configuration I am not getting an expected result.

Further in the browser when I provide the url https://<proxy_hostname>:<proxy_port>/jts it gets redirected to https://<proxyhostname>:<clm_port>/jts/auth/authrequired

Here the proxy server name remains the same in the url but the port and the rest of the url changes.

Other details is as follows,
CLM v6.0.2
Squid v3.4.4.2
Websphere Application server v8.5.5.5
DB2 v10.5
CLM is installed on Windows 2012 R2 server
Squid is installed on RHEL 6.4

Any help is much appreciated and thanks in Advance.

Regards,
Nicky Chris John


Comments
Geoffrey Clemm commented Nov 17 '16, 7:17 p.m.
FORUM ADMINISTRATOR / FORUM MODERATOR / JAZZ DEVELOPER

I have created a work item: Test version 3.5 of the Squid content cache with version 6.0.3 of RTC (406281)
Please either add comments to this work item describing Squid problems or bugs that you've encountered, or attach submitted defects.

2 answers



permanent link
Harshavardhana N Reddy (112) | answered Nov 20 '16, 11:41 p.m.
JAZZ DEVELOPER
edited Nov 20 '16, 11:42 p.m.
Guessing that you might have hit the problem mentioned in the following Technote - http://www-01.ibm.com/support/docview.wss?rs=3488&uid=swg21405179

Have you done this setting on WAS server? If not, let me know having this setting on WAS solves the problem that you are seeing on your setup.

Comments
nicky john commented Nov 20 '16, 11:52 p.m.

 Hi,


Thanks but the issue has already been resolved.

It was an issue with the squid port. After changing the port number, I was able to access CLM through squid.

Neways thank you for the support.

Regards,
Nicky C.J


permanent link
nicky john (315) | answered Nov 25 '16, 11:18 a.m.
edited Nov 25 '16, 11:19 a.m.
 Hi,

I was able to access CLM through squid with the configuration specified in the initial query.

Now i have changed the configuration and the new configuration is as follows,,
Server 1 : JTS, CCM
Server 2 : QM
Server 3 : Squid

Now I am able to access JTS and CCM through squid but not QM.

Details is as follows,
CLM v6.0.2
Squid v3.4.4.2
CLM is installed on Windows
Squid is installed on RHEL 6.4

I have even added separate cache_peer for each servers in the squid.conf file.

It would be of great help if someone can let me know the procedure to access all the applications through squid.

Regards,
Nicky C.J

Your answer


Register or to post your answer.