It's all about the answers!

Ask a question

Quick Search does not find defects and enhancements


Will Girard (154) | asked Nov 09 '16, 8:01 a.m.
retagged Nov 18 '16, 4:01 a.m. by Minakshi Jaint (5113)
 Hello

We just upgraded our CLM installation from 4.0.6 to 6.0.2 iFix2. Now we found out, that the quick search does not return defect and enhancement work items.

In 4.0.6 i was able to enter a defect-id or a text on the top right quick search field and it returned the link to the corresponding defect(s).

In 6.0.2 i only see test plans, test scripts etc. but no enhancments and defects. if i click on more options on the quick search, all items are checked. But i saw that there is no checkbox for "Work Items" or "Defects".

I also tried the following commands to rebuild the indexes:
repotools-jazz.bat -rebuildTextIndices
repotools-jazz.bat -reindex

Do i have to configure something special to search for defects or enhancments in the quick search bar?

Thank you very much in advance.
Willi


Comments
Donald Nong commented Nov 10 '16, 4:19 a.m.

Are you referring to the RQM "local" defects and enhancements? It seems that you're still using the "jazz" context root - is your environment upgraded from an even older version?


Will Girard commented Nov 10 '16, 4:39 a.m.

Yes we have upgraded from RQM 2 or 3 to 4, about 2 years ago. And now from 4 to 6. So we are using the old "jazz" context root.


if i go to the "Work items home" (https://<URL>/jazz/web/console/<Project>#action=com.ibm.team.workitem.viewWelcome) it finds the defects. But in the "quick search" it does not work.



Donald Nong commented Nov 10 '16, 7:25 p.m.

I have never worked on such environment before, and am not sure whether you are using RTC. If the defects are in RQM, they are sometimes referred to as "local defects", versus those in RTC as "remote defects". If during the upgrade the "local defects" somehow got migrated to RTC as "remote defects", that can explain why you can no longer "quick search" them. So you will need to determine where these defects are located now.


Will Girard commented Nov 11 '16, 4:23 a.m.

 Thank you. Do you know how i can see if my defects got migrated to RTC?


For migration in followed the official IBM documentation:

From 4.0.6 to 5.0.2
upgrade\jts\jts_upgrade.bat -oldJTSHome D:\IBM\JazzTeamServer_4.0.6\server\conf
upgrade\ccm\ccm_upgrade.bat -oldApplicationHome D:\IBM\JazzTeamServer_4.0.6\server\conf
upgrade\jazz\qm_upgrade.bat -oldApplicationHome D:\IBM\JazzTeamServer_4.0.6\server\conf
upgrade\rm\rm_upgrade.bat -oldApplicationHome D:\IBM\JazzTeamServer_4.0.6\server\conf -newJTSHome D:\IBM\JazzTeamServer5.0.2\server\conf
repotools-rm.bat -rmUpdateProjectBacklinksOnline adminUserId=MyAdminUser adminPassword=* repositoryURL=https://quality.swisspost.ch/rm


Will Girard commented Nov 11 '16, 4:23 a.m.

 From 5.0.2 to 6.0.2

upgrade\jts\jts_upgrade.bat -oldJTSHome "D:\IBM\JazzTeamServer5.0.2\server\conf" -updateTomcatFiles yes
upgrade\ccm\ccm_upgrade.bat -oldApplicationHome "D:\IBM\JazzTeamServer5.0.2\server\conf" -updateTomcatFiles yes
upgrade\jazz\qm_upgrade.bat -oldApplicationHome "D:\IBM\JazzTeamServer5.0.2\server\conf" -updateTomcatFiles yes
upgrade\rm\rm_upgrade.bat -oldApplicationHome "D:\IBM\JazzTeamServer5.0.2\server\conf" -updateTomcatFiles yes


Donald Nong commented Nov 13 '16, 6:03 p.m.

I would suggest you contact Support for this one so that more information can be collected to understand the issue. I've run out of ideas, sorry.

showing 5 of 6 show 1 more comments

2 answers



permanent link
Lily Wang (4.9k714) | answered Nov 09 '16, 11:02 p.m.
Could you please check if you can find the work item if running the quick search from a RTC project area?
My understanding is running quick search in RQM project area will not return defects created in RTC. This is working as designed.

Comments
Will Girard commented Nov 11 '16, 4:08 a.m.
Maybe a very dumb question, but how can i see if my project is in RTC or in RQM?

I guess i have three project areas, Quality Management (/jazz), CCM (/ccm) and RM (/rm)

Donald Nong commented Nov 11 '16, 4:18 a.m.

Just check the context root after you open the project. If it's /jazz, it's in RQM.


Will Girard commented Nov 11 '16, 8:58 a.m.

Im in the context root /jazz while using the quick search and the work items also have /jazz context root. Here is an example link to a defect:



Will Girard commented Nov 13 '16, 7:14 p.m.

Im still no sure if my defects are in RQM because the namespace in the links to a test script begins with com.ibm.rqm, if i open a defect the namespace in the URL is com.ibm.team. So it could be that the work items are in RTC?


Donald Nong commented Nov 13 '16, 8:23 p.m.

It's probably more reliable to check the shortcut of the WI (right-click on the icon and copy location), or use Firebug to check which resource URI is accessed for retrieving the WI information. If you accept that the defects are in RTC, then you should also accept that quick search in RQM will not find them.


Lily Wang commented Nov 13 '16, 8:25 p.m.

You can follow the URL:

to check if the RQM project is part of the lifecycle project, or if it has an association with a RTC (CCM) project area.
If it doesn't match the above two cases, the RQM manage the defect itself which means it use local defects.

showing 5 of 6 show 1 more comments

permanent link
Villarasan Kumar (11) | answered May 18 '17, 9:59 a.m.

 I have the same issue, recently we migrated from QM 406 to 603 and we are not seeing the work items option in the Quick Search, so what is the fix for this issue or is it the limitation in this version.


thanks
Vills


Comments
Will Girard commented May 18 '17, 10:46 a.m. | edited May 18 '17, 10:52 a.m.

Hi Kumar


This issue is registered at IBM under defect 159367.

The defect 159367 is planned for 6.0.4.

I think 6.0.4 will be released soon.

Regards
Willi

<o:p> </o:p>

<o:p> </o:p>

Your answer


Register or to post your answer.