It's all about the answers!

Ask a question

mainframe load directory


Vivek Pandey (4321029) | asked Oct 12 '16, 4:52 a.m.
 Hi,

while using mainframe ANT based builds within RTC V 6.0.2, we dont see Load directory (teamz.scm.fetchdestination) getting all files from RTC component. 

Is that expected behaviour ? 
IS the load directory behaviour different between distribtued and mainframe ?

5 answers



permanent link
Nicolas Dangeville (3062023) | answered Oct 17 '16, 10:23 a.m.
JAZZ DEVELOPER
I assume you're using a build template z/OS dependency build.

Here's how it works, and yes it's a bit different from distributed because we have a way to recognize MVS content from USS content.

What's loaded on USS:

In the build definition, in the tab Jazz Source Control, there is a check box "load workspace to the load directory at the beginning of the build"
If it is unchecked, nothing will be loaded on USS.

If it is checked:
All the projects that are not zComponent Projects (e.g. Java projects) will be loaded fully in the load directory.
For the projects that are zComponent Projects, everything will be loaded, except the folder zOSSrc and its subfolders. These ones are meant to be loaded on MVS, in the Resource Prefix (each folder under zOSSrc is pointing to a data set definition).

Thanks,

Nicolas



permanent link
Vivek Pandey (4321029) | answered Oct 17 '16, 11:28 a.m.
 Hi Nicolas,

Thanks for the response !
We are already trying the dependency builds for the first time with the option you mentioned above, but running into Jazz Build Toolkit compatibility related error, which we are following as PMR with IBM separately.

I will keep you posted on this thread, once that issue is resolved and we are able to run Dependency build.

Is this option not available in any of the other build definitions for zOS ?



permanent link
Vivek Pandey (4321029) | answered Oct 17 '16, 11:42 a.m.
 Also, I tried the Build definition type 'ant with Enterprise Extension - Rational Build Agent'.
The build goes through without any error, but the files still didn't get loaded to the fetchDestination folder.

To verify, we also ran 'ls -lR' command but it only shows that some ant build*.xml and folder exists within Load directory.

Here are some text excerpts from the log file , which has 'ls -l' output of the load directory.



ENV teamz.scm.fetchDestination=/tmp/Vivek
ENV teamz.scm.workspaceUUID=_i8iKQH9HEeasraq4FpWn8Q
ENV ANT_HOME=/usr/lpp1/jazz/hd/buildsystem/buildengine/eclipse/plugins/org.apache.ant_1.7.1.v20100518-1145
ENV BF_AGENT_DEBUG=1
ENV BF_AGENT_PLATFORM=os/390 24.00 04
ENV BF_AGENT_VERSION=8.0.0.2-4-0009
ENV BLD_TOOLKIT=/var/jazz/buildtoolkit:/usr/lpp1/jazz/hd/buildsystem/buildtoolkit
ENV HOME=/tmp
ENV JAVA_HOME=/usr/lpp1/java/y3/J7.0
ENV ZLANG=IBM-037
EXEC ExecPreparse
EXEC spawning shell "/bin/sh"
SCRIPT ls -lR /tmp/Vivek/
SCRIPT ls -lR /tmp/Vivek/GD
SCRIPT cp -R /tmp/Vivek/*.xml /tmp/Sudesh
EXEC start "/tmp/Vivek"@"RD01"
* /tmp/Vivek/:
* total 112
* -rwxrwxr-x   1 STCRTC   0            223 Oct 17 11:32 FAOperationList.xml
* drwxr-x---   3 STCRTC   0           8192 Oct 17 11:32 GD
* -rwxrwxr-x   1 STCRTC   0           1352 Oct 17 11:32 build.properties
* -rwxrwxr-x   1 STCRTC   0            842 Oct 17 11:32 buildableFiles.xml
* -rwxrwxr-x   1 STCRTC   0           4924 Oct 17 11:32 generatedBuild.xml
* -rwxrwxr-x   1 STCRTC   0           3769 Oct 17 11:32 macrodefs.xml
* -rwxrwxr-x   1 STCRTC   0           7830 Oct 17 11:32 rtczBuild.xml
* /tmp/Vivek/GD:
* total 16
* -rw-r-----   1 STCRTC   0           2144 Oct 17 11:32 build.xml

Comments
1
Nicolas Dangeville commented Oct 18 '16, 12:02 p.m.
JAZZ DEVELOPER

Yes the ant with enterprise extensions build works the same as far as the load is concerned (but there are less options to tune):
everything is loaded in loaded in USS except the zOSSrc folders and their subfolders, that go to MVS.

I assume that GD is the name of your zComponentProject.

It's true also that the build generates a few XML files, to drive the ant build, that are placed in the load directory as well.



Vivek Pandey commented Oct 19 '16, 12:15 p.m.

Hi Nicolas,

Thanks a ton for pointing out that one.

Indeed, GD was zOS Folder that was created from RDz, that may have been the reason why it was not getting loaded on UX filesystem.

I created non zOS folder for RTC eclipse client, and it got loaded along with all files inside it.



permanent link
Vivek Pandey (4321029) | answered Oct 24 '16, 10:44 p.m.
Hi Nicolas,

We are able to get the file now in unix filesystem of mainframe, however file-contents have got converted into some junk characters.

When we do 'cat' on the file on mainframe, it does not show what we had typed-in before delivering to RTC.

Is there any character encoding issue here ? 

permanent link
Vivek Pandey (4321029) | answered Oct 27 '16, 1:11 a.m.
Hi Nicolas,

Here is the output of the 'Cat' command which we are executing as part of the 'Post-build' action.
As your can see below, the file contents are not readable, whereas in RTC, the it is readable line.

SCRIPT cat /tmp/Sudesh/Java/non-zOSsrc-Folder/java/SampleFile.java

* ŠèÇÑˀÑˀË/_ø%Á€ÃÑ%ÁŠ

IN RTC, this is what file contains:
/*This is sample file*/



Comments
Nicolas Dangeville commented Oct 31 '16, 5:02 a.m.
JAZZ DEVELOPER

On z/OS, the default code page is EBCDIC. For members in PDS, you certainly want to load the text content in EBCDIC. For the files on USS, it depends, and we offer options to load either in EBCDIC or ASCII.

We have rules to convert files to EBCDIC or not, based on their locations and properties.
Binary files (aka files that are not recognized by RTC as text files) will not be converted.
Text files in a zFolder will be converted to EBCDIC. This is either to the code page specified by the ZLANG env variable or the code page of the system.
You can override this code page on specific zFiles by using the user property mvsCodePage.

For files in zComponentProject but not under zOSSrc (the files that will be loaded on USS), the file will be converted or not based on the property mvsCodePage.

You have detailed explanations on this mechanism on this page: https://www.ibm.com/support/knowledgecenter/SSYMRC_6.0.3/com.ibm.team.scm.doc/topics/r_ee_mvscodepagefileproperty.html


Vivek Pandey commented Oct 31 '16, 6:15 a.m.

 Hi Nicolas,

Thank you very much for the answer !

we have non-zOS component under the zcomponent. ( is that restriction in first place) ?
secondly, we are using RTC V6.0.2, so does above still hold good ?

Thirdly, how to set the property of mvscodepage ? does it need to be set on every file using command line ? 
I have tried various ZLANG values as build property but none of them actually help.


Vivek Pandey commented Oct 31 '16, 6:16 a.m.

 sorry, let me correct a statement,

We have non-zOS folder under zComponent.

Your answer


Register or to post your answer.