It's all about the answers!

Ask a question

Jenkins integration with RTC

N. VD (842634) | asked Apr 01 '16, 10:28 a.m.
edited Jun 17 '16, 12:49 p.m. by David Lafreniere (4.8k7)
I'm trying to integrate with Jenkins from RTC.
My Jenkins server is running on a SSL.

When clicking the 'Test Connection' button in Eclipse (Created a Build Engine to Jenkins), i'm getting this error:
Connection test requested.
Connecting to:
Exception: PKIX path building failed: PKIXCertPathBuilderImpl could not build a valid CertPath.; internal cause is: The certificate issued by CN=DigiCert High Assurance EV Root CA,, O=DigiCert Inc, C=US is not trusted; internal cause is: Certificate chaining error
Test connection FAILED!

So i browsed to the URL and downloaded the certificates as DER files & added to the keystore:
(repeated it for root and intermedate CA's):
keytool -importcert -alias rhcloudroot -keystore /opt/IBM/JazzTeamServer/server/liberty/servers/clm/resources/security/ibm-team-ssl.keystore  -storepass ibm-team -file /opt/certs/rhcloud.cer

  • Per test i also ran the ikeyman script as described here:

  • I also tried this the --autoAcceptSigner as described here, but the server wouldn't start:

Still getting the same error... any toughs?

Accepted answer

permanent link
Natarajan Thirumeni (298731) | answered Jun 15 '16, 5:51 a.m.
We've had a  same issue. You need to ensure the JRE cacerts keystore has Jenkins server certificates. We are able to get past the connection issue. Please check and if you're running into issue feel free to open a PMR with IBM support team.
N. VD selected this answer as the correct answer

One other answer

permanent link
Sridevi Sangaiah (59179) | answered Apr 02 '16, 2:13 a.m.
edited Apr 02 '16, 2:32 a.m.

Just want to confirm if you are importing and installing the certificates to the jre that is used to run the RTC client.


N. VD commented Apr 04 '16, 3:26 a.m.

Hi Sridevi, 

Thanks for your answer,

I've added the root certificate in all .keystore & cacert files i found on my server (Ubuntu Linux). in most of the files, the certificate was already added by default. My client is also present on my server machine & i'm testing from there.

Still no luck.

Lakshmi Narasimhan T V commented Apr 04 '16, 6:27 a.m.

Could you check whether importing your certificate into the jre used by the server solves the issue?

N. VD commented Apr 06 '16, 3:40 p.m.

 Done that, still same error

Your answer

Register or to post your answer.

Dashboards and work items are no longer publicly available, so some links may be invalid. We now provide similar information through other means. Learn more here.