It's all about the answers!

Ask a question

Repotools error during CCM upgrade from 5.0.2 to 6.0.1


Francis Kemp (7212334) | asked Mar 09 '16, 3:11 p.m.
When I run the command:

./repotools-ccm.sh -migration_ccm_updateConfigurationFiles oldApplicationHome=/data/IBM/JazzTeamServer/server/conf ignoreJTSVersionCheck updateTomcatfiles=no updateAppServerFiles=no

I get this error:

Provisioning using :./conf/ccm/provision_profiles"
Plug-in com.ibm.team.interop.service.managers.kernel was unable to load class com.ibm.team.repotools.commands.upgrade.ccm.CCMUpdateConfigurationFilesCommand
CRJAZ1728E A Repository Tools error occurred..

The JTS server upgrade ran fine.  In the repotools/ccm/eclipse/configuration directory, I'm getting errors like this:

BundleException:  The activator org.eclipse.equinox.internal.ds.Activator for bundle org.eclipse.equinox.ds is invalid.

Anyone seen this before?  We're running on zLinux.

Thanks

One answer



permanent link
Alexandre Stegani (8664) | answered Mar 09 '16, 5:19 p.m.
Are there any other errors in the output .log file created by this repotools command? I don't think this "BundleException" is the root cause of the problem here.

Also please try running ./repotools-ccm.sh -clean and then try it again.

Comments
Francis Kemp commented Mar 09 '16, 5:35 p.m. | edited Mar 09 '16, 9:33 p.m.


Thanks! 

Running repotools.sh -clean fixed the issue and allowed the -migration_ccm_updateConfigurationFiles and -addTables to run successfully. 

This is my first upgrade in a distributed Linux environment - done lots in Windows.  Never had to run that in Windows.  Is this something that needs to be run in Linux before every upgrade?

Thanks again,
Fran


Alexandre Stegani commented Mar 09 '16, 5:58 p.m.

Hi Francis,

Glad it worked! The -clean option forces repotools to reprovision. It is not OS related.

Usually it is required when installing an iFix or to resolve such issues with repotools


Francis Kemp commented Mar 09 '16, 6:00 p.m. | edited Mar 09 '16, 9:33 p.m.

Please have someone add this to the upgrade instructions...  :)

Your answer


Register or to post your answer.