It's all about the answers!

Ask a question

How to create bug from taskboard?

Miroslav Senaj (112) | asked Feb 29 '16, 7:30 a.m.
edited Mar 28 '16, 4:27 p.m. by Lisa Frankel (5462)
I'm really wondering how to create bug in taskboard.
I'm trying to create child bug for story from taskboard.

It will create bug, I will specify description and try to save it.

It will not save bug because of missing 'Defect type'. There is no 'Defect type' in taskboard view. So I try to edit bug.

But there is no 'Defect type' in this edit view either.

So my question is how to create bug from taskboard? Why are not all mandatory fields in edit view?

I know I can create new bug from other view where is 'Defect type' but there I need to assign Iteration and other additional stuff.

One answer

permanent link
Shawn Maclaga (1963) | answered Feb 29 '16, 8:56 a.m.
Have you tried editing the taskboard plan view?
There should be three tabs:
Column Display
Card Display

On the Card Display tab, click to add an attribute, select the attribute that you need (Defect type).
Ensure that the attribute is set to display on all three card sizes and try again.

This help topic discusses customizing the Kanban and Taskboard plan views:


Miroslav Senaj commented Feb 29 '16, 9:47 a.m. | edited Feb 29 '16, 12:13 p.m.


I have tried Card Display but there is no "Defect type" either. I cannot add it because its not in list.


Shawn Maclaga commented Feb 29 '16, 10:45 a.m.

Are you able to create a bug from any of the plan views?
I'm going to assume the answer to this question is no, in which case you need to add the work item attribute (Defect type) as a plan attribute. To do this, see:
Once you've done this, you should be able to add the attribute to the Taskboard plan view.

If you also need to add the attribute to the plan view's inline editor, you'll need to modify the Plan Editor Preview for the bug work item type.
From the project area configuration page in the web client:
- navigate to Work Items / Types and Attributes
- Select the bug work item type
- Hover the Plan Editor Preview row, and click the pencil icon that shows up to the right on hover
- Add the appropriate presentation for your defect type attribute

Matt Muller commented Mar 02 '16, 4:45 a.m.

Good Afternoon,

I've seen this as an "Exclude" setting in the Plan Options:

It maybe an exclude Option in some way.

Your answer

Register or to post your answer.