It's all about the answers!

Ask a question

Is it possible to link a RTC project in a repository at v6.0.1 to a RQM project in repository at v4.0.3


Prasad Vasiraju (1547) | asked Feb 25 '16, 11:12 a.m.

We have a RTC project in a repository (JTS and RTC version 5.0.2) linked to RQM projects in repository (JTS and RQM version 4.0.3).

We are looking to upgrade the first repository with the RTC project to v6.0.1. We are trying to determine if the repository containing the RQM project can remain at 4.0.3 for the time being. I have not seen any guidance on this in the research I did so far.


Comments
Surya Tripathi commented Feb 25 '16, 8:40 p.m.

How are the projects in RTC and RQM linked together? Could you please explain?


Prasad Vasiraju commented Feb 26 '16, 9:21 a.m.

The defects in RTC project would be linked to RQM work items with a  "is tested by test case" link. I linked the projects across repositories not by creating a lifecycle project but manually following instructions in the link below (skip step 2 for lifecycle project)

https://www-01.ibm.com/support/knowledgecenter/SSCP65_5.0.1/com.ibm.rational.test.qm.doc/topics/t_config_rtc_defects_overview.html

One answer



permanent link
Paul Tasillo (10665) | answered Mar 03 '16, 8:19 a.m.
JAZZ DEVELOPER
Hi. The bottom line is no. We support n-1 version compatibility. RTC 6.x can integrate with RQM 5.x but not 4.x.

In your scenario if RTC is coming from 4.x you will need to upgrade to 5.x and then 6.x. It is not possible to directly migrate from 4.x to 6.x. I'd suggest you move step wise with the migration to maintain compatibility.


Your answer


Register or to post your answer.