It's all about the answers!

Ask a question

Enumerated Values not displaying in custom fields


Glenn Watkins (88245) | asked Jan 18 '16, 9:44 a.m.
 Hi

We are using RTC V 5.0
I have a situation where the enumerated values are not displaying in the custom fields on two of our work items, these are user selected drop down fields. When the user activates the drop down, the window that appears that holds all the values is empty. On work items where values have been selected previously, the field displays the enumerated key, (za.co.example.workitem.literal.l5) as opposed to the enumerated value (medium).

Any and all assistance will be greatly appreciated.

Kind Regards
Glenn

Accepted answer


permanent link
Ralph Schoon (62.9k33645) | answered Jan 18 '16, 9:47 a.m.
FORUM ADMINISTRATOR / FORUM MODERATOR / JAZZ DEVELOPER
If you see the literal in old ones, that basically means that the enumeration is no longer available or corrupted or something, for all I know. That would also match to not seeing any values for work items that have them not set.

Check your process configuration for the enumeration. Has someone changed the ID in the process configuration source or otherwise changed the process to break it?
Glenn Watkins selected this answer as the correct answer

Comments
Glenn Watkins commented Jan 25 '16, 1:20 a.m.

 Hi Ralph


Thanks again for taking the time to respond. It was corrupted data, our environment is very integrated, all projects use the same "Master Process Configuration", what had happened was each individual project area's "Process Configuration Source" file was populated and this was causing the conflict with the "Master Process Configuration Source".xml once I cleared all project areas "Process Configuration Source" .xml and my values returned to normal.

Thanks again.

Glenn


Ralph Schoon commented Jan 25 '16, 2:13 a.m.
FORUM ADMINISTRATOR / FORUM MODERATOR / JAZZ DEVELOPER

Thanks for sharing the explanation Glenn.

Your answer


Register or to post your answer.