It's all about the answers!

Ask a question

Display Embed artifacts in RPE


Erwin Kunz (94685977) | asked Jan 11 '16, 9:32 a.m.
CLM 6.0.0

Hi there

I have a RPE report where I create the data connection by scripting. If I'm not wrong, till 5.0.2 I was able to display the content of embedded artifacts by adding following to the Rest URL &showEmbedTitles=true

Today it just display the Title as Hyperlink.

The build-in RPE Requirement Spec report, has a prompt : Show Embedded Artifacts Maximized

Unfortunately I've no clue how it is used in the report. How do I need to integrate it in my user defined report?

Thank you
erwin

8 answers



permanent link
Erwin Kunz (94685977) | answered Jan 12 '16, 11:08 a.m.
use
   &showEmbedTitles=true to display the Name with hyperlink
   &maximiseEmbeds=true to display the whole artifact

permanent link
Gaurav Tapadkar (269) | answered Apr 25 '17, 6:14 p.m.

 Hello Erwin,


Are you referring to the Requirements Specification report in the RM component? I am facing the similar issue where the "Requirements Specification Report" is not showing the embedded artifacts in the report. It is skipping the embedded artifacts.

From the UI, there is no option to maximize and display the embedded artifacts. However, from your comment, it looks like you found an option to do it via REST API by adding 
   &maximiseEmbeds=true to display the whole artifact 

Can you give me a complete sample command to generate the report via REST API? Also, point me to the REST API documentation.

Regards,
Gaurav


permanent link
Kenji Sarai (96028) | answered Apr 25 '17, 10:35 p.m.

Hi Gaurav,

Here is the complete sample for Reportable REST URL.
https://server:port/rm/publish/text?resourceURI=UUID&maximiseEmbeds=true

For documentation,
https://jazz.net/wiki/bin/view/Main/DNGReportableRestAPI
See "Expand embedded artifacts", it works for text artifact type.


permanent link
Gaurav Tapadkar (269) | answered Apr 25 '17, 11:43 p.m.

Hello Kenji,


Thanks for your reply. I am generating a single Requirements Specification report (Document Style Report) of all the artifacts from a particular project in  RRC. This report is generated from the UI and it is in the PDF format. 

None of the embedded artifacts are are showing in the PDF report. However, If I generate a PDF report of a single artifact, I can see the embedded artifact.

I am specifically looking for an option to show embedded artifacts in the report. 
  1. Is it possible to add any extra parameter in the UI to show the embedded artifacts?
  2. Is there any equivalent REST API call to generate a PDF report of all the artifacts from a project. The report should include the embedded artifacts as well.
Regards,
Gaurav




permanent link
Erwin Kunz (94685977) | answered Apr 26 '17, 3:58 a.m.

My hint was thought in case you have to create your own report.

If you use the build-in, you have just to check the box "Show Embedded Artifacts Maximized" on the Report Prompt UI

I run the test on 6.0.2 and it works as expected


permanent link
Gaurav Tapadkar (269) | answered Apr 26 '17, 7:03 a.m.

 Hi Erwin,


Its good to know that this issue is fixed in the newer release. Unfortunately, I am  using 4.0.4 version of the Jazz and do not have any option to "Show Embedded Artifacts Maximized"

Is there any chance to use this option in 4.0.4?

Regards,
Gaurav


permanent link
Gaurav Tapadkar (269) | answered Apr 27 '17, 9:11 a.m.

 Hello Erwin, Kenji,


Do you have any suggestions on getting the embedded artifacts in the jazz 4.0.4 version?

Regards,
Gaurav


permanent link
Kenji Sarai (96028) | answered Apr 27 '17, 8:35 p.m.

Hi Gaurav,

You can add these parameters (&maximiseEmbeds=true&showEmbedTitles=true) in the data source schema in RPE.
 
However, according to the old RRC Reportable REST specification
https://jazz.net/wiki/bin/view/Main/RRCReportableRestAPI

showEmbedTitles is introduced in 3.0.1.3, but maximiseEmbeds is not listed here. So I am afraid this is not available in 4.0.4. Just give it a try. If it does not work, perhaps you need to upgrade to version 6.

Your answer


Register or to post your answer.