It's all about the answers!

Ask a question

RTC Preconditions and Follow up Actions


Glenn Watkins (8831) | asked Nov 08 '15, 10:13 a.m.

Hi

We are using RTC v 5.0

I am trying to configure "read only attributes for type and state" on certain roles, when I configure this setting it seems to cancel the "required attributes for type and state" settings, so I loose all my mandatory fields when this is applied.

Any and all assistance will be greatly appreciated.

Kind Regards

Glenn

Accepted answer


permanent link
Ralph Schoon (58.2k23642) | answered Nov 08 '15, 11:07 a.m.
FORUM ADMINISTRATOR / FORUM MODERATOR / JAZZ DEVELOPER
Read
  to understand how operational behavior works. Note, only the first configuration for the first role found is used. Otherwise, for the first role found, all operational behavior specified is executed.
Glenn Watkins selected this answer as the correct answer

Comments
Glenn Watkins commented Nov 08 '15, 11:13 a.m.

 Hi Ralph

Once again,  thank you for answering, we have used the "everyone" option in the main configuration,  should I cancel thst setting and configure each role seperately?

Just to let you know I am currently working through the PEW it is extremely beneficial thank you.

Kind Regards
Glenn


Ralph Schoon commented Nov 09 '15, 2:43 a.m.
FORUM ADMINISTRATOR / FORUM MODERATOR / JAZZ DEVELOPER

Glenn,

I usually configure the basic stuff for the everyone role.
But the the built in Required and Read Only by type and state in this case work only for the Everyone role. If you want this to work for specific roles, then you need to configure it there. And then you have to understand that only the first  configuration found for a role is executed, so if you have other behavior you want to be executed, you also need to configure that for the role. This can be a lot of work and is hard to maintain.

I have done some work here: https://rsjazz.wordpress.com/2015/08/07/a-custom-condition-to-make-attributes-required-or-read-only-by-role-version-2/ . It allows to configure for everyone, but that is also not an ideal solution.



Your answer


Register or to post your answer.