It's all about the answers!

Ask a question

How can I create a new Work Item type in RTC 4.0.2?


Ryan McBryde (361822) | asked Feb 11 '14, 6:58 p.m.

I was hoping that someone can point me quickly to where the problem lies.

I am trying to create a new work item type called a DBCR (Database Change Request) in my sandbox project area, which is using the process configuration from another project area. 

 I wanted to base my new WI on an existing WI type;  workflow, attributes, presentation, etc.

 I duplicated and renamed the exiting WI workflow.  The id of the original workflow was “com.acn.adt2.workitemtype.defect”  and I gave the new workflow the id of “com.acn.apsp.workitemtype.dbcr.”

 I also duplicated  and renamed the WI Editor Presentation. Original = “com.acn.adt2.workitem.editor.defect” and New = “com.acn.apsp.workitem.editor.dbcr.”

 I edited the inline editor presentation and duplicated the entry for the WI, “com.acn.adt2.inline.editor.defect” to APSP DBCR, “com.acn.apsp.inline.editor.dbcr”

 I was able to do all of this without any error or problem.

 Then I went to create the new WI type itself, which would use the new workflow and editor presentations.

 Under Project Configuration->Configuration Data->Work Items->Types and Attributes I clicked the Add button and entered the following data:

 Name:                  APSP DBCR

ID:                          com.acn.apsp.workitemtype.dbcr

Category:            com.acn.apsp.category.dbcr

 I selected the new workflow and the new editors and then clicked Save and got the attached error message, stating,

 "Items with a protected read access policy must use a public context id, a project id, or a current contributor id but the id "LAVyIBTZEeOHNPHsouTwGQ" was used"

 And I could not go forward and save this new WI.

 So, I tried again, this time keeping it within the “com.acn.adt2” framework, so the new WI info was:

 Name:                  ADT DBCR

ID:                          com.acn.adt2.workitemtype.dbcr

Category:            com.acn.adt2.category.dbcr

 This time I did not select any values for editors or workflow and just tried to save the new WI, and I got the same error.

 I googled the error and only found one entry from IBM and Jazz,  https://jazz.net/forum/questions/58078/error-message-after-upgrading-from-2002-to-301?redirect=%2Fforum%2Fquestions%2F58078%2Ferror-message-after-upgrading-from-2002-to-301 but this is very much focused on the after effects of upgrading an RTC instance, which I am not doing.

 According the only documentation that I could find on this topic; https://pic.dhe.ibm.com/infocenter/clmhelp/v4r0m2/index.jsp , I should be able to create new work item types.

 I profess to have no clue whatsoever as to what the values used in the ids of the workflows, editors, and work item types represent,  com.acn.adt2,  for example.  I don’t know if I have to create something else before I can try to create “com.acn.apsp.workitemtype.dbcr”.  This is the first time that I have attempted to create a new work item type and because this is for a different organization, I thought that it made sense to use this syntax, "com.acn.apsp."

Any guidance or insight that you can provide would be very much appreciated. 


Comments
sam detweiler commented Feb 11 '14, 7:17 p.m.

Al of my custom workitem types have used the stock category as a base


com.ibm.team.workitem.workItemType.newtype 

the ID can be anything. 

One answer



permanent link
Piotr Aniola (3.6k1635) | answered Feb 12 '14, 4:44 a.m.
Yes, you should be able to create new workitem types.
Here's how I do it.
1. In Eclipse, open the project, Process Configuration -> Project Configuration -> Configuration Data -> Work Items -> Types and Attributes
2. Select Add, put myworkitemtype as name and ID, Save
3. Go to Workflows, select defect workflow, duplicate, set myworkflow as name, Save
4. Back to myworkitemtype, select myworkflow from the Workflow dropdown, Save
5. Go to Editor Presentations, select the default presentation, duplicate, set mypresentation as name, Save
6. Back to myworkitemtype, select mypresentation from Work Item Editor dropdown, Save

Please let us know if the above procedure works for you. Saving after each operation will help us see at what point is there a problem, if any. Note that I tested this on the standard scrum template.

Your answer


Register or to post your answer.