It's all about the answers!

Ask a question

RQM: Test script name do not appear by default when created from within Test Case section


Rajesh Avanthi (10814115171) | asked Oct 16 '15, 6:59 a.m.
With one Test script associated to one TestCase, and when you execute the TestCase , by default the Testscript name does not appear and shown as "None".
This behavior is only seen when you create a TestScript from within the TestCase section.


However if the Test script is created outside the Test Case section and then add the Test script to Test Case, you could see that by default the test script name appears when the test case is executed.

Why do we have a difference in this behavior ??

2 answers



permanent link
Ted Mayer (4515) | answered Oct 16 '15, 9:15 a.m.

Hello Rajesh,

What version of RQM are you using, I just tested with RQM 5.0.2 and when executing the Test Case, the Test Script was automatically associated when running the Test Case. The behavior was the same whether I created the Test Script at the time when I created the Test Case, or if I created the Test Script separately and then added it to the Test Case later.

Regards,

Ted


permanent link
paul chu (59411) | answered Oct 16 '15, 10:16 a.m.
JAZZ DEVELOPER
There should not be any difference and I am not seeing it in the latest release.  It can happen if there is an existing TCER that doesn't use any test script.  When running the test case, the existing TCER will be selected and show "None" even there is a test script associated to the test case.  That is just showing what is associated with the TCER.

If there is a way somehow to trigger this difference, please submit a defect with the version of QM you are using and the detail steps on how to reproduce the problem.

Your answer


Register or to post your answer.