It's all about the answers!

Ask a question

Error during RTC 5.0.2 extensibility

Nikita Dhande (35110) | asked Oct 15 '15, 3:17 a.m.

I m working on RTC 5.0.2 extensibility.

I have followed all the steps of WorkshopSetup pdf, but am getting error in one step: (Test connecting the Eclipse debugger to Tomcat) Navigate -> Open Type ->
ActiveServiceDTO. I cannot see this option in the available types.

Have I gone wrong somewhere in the steps or anywhere else?

One answer

permanent link
Ralph Schoon (62.3k33643) | answered Oct 15 '15, 3:22 a.m.
What you describe is not an error, but you don't see what you expected to see. I would suggest to carefully perform the lab 1 steps before this one. You likely experience one of the following problems:

  1. Failed to setup the client with the SDK Target Platform
  2. Missed to add the Target Platform's Plugins to the Java search

Nikita Dhande commented Oct 15 '15, 3:35 a.m. | edited Oct 15 '15, 3:40 a.m.

 I have followed both these steps correctly.

Also I am getting many errors in Eclipse Client Error Log.

Ralph Schoon commented Oct 15 '15, 4:15 a.m.

If you did, you would be able to find that class. I have done this with almost all versions of RTC since 3.0 and it always worked. Experience shows it is not a problem with the workshop, it is usually user errors e.g. not checking the right check boxes during the import steps for the SDK and while setting up the workspace.

I tried to see your errors in Eclipse using my crystal ball. Didn't work.

Your answer

Register or to post your answer.