It's all about the answers!

Ask a question

Customizing plans to include story point


Alex Feinberg (2652) | asked Jul 24 '09, 11:43 a.m.
Greetings,
Is there a way to customize the backlog view of my plans to include the story points? In my Eclipse client, I am looking at my backlog view of my plan and I have an edit button (new in R2.0 I think), but when I edit the view, the list of attributes does not include story points, or any of my own custom attributes. I'm guessing that story points is not a native attribute, but is part of the scrum template that we're using. So I suppose the question is more general... Can I customize my plan backlog view to include non-native (i.e. custom attributes)?
Thanks,
Alex Feinberg
feinberg@us.ibm.com

4 answers



permanent link
Michael Walker (99214198157) | answered Jul 24 '09, 12:14 p.m.
Greetings,
Is there a way to customize the backlog view of my plans to include the story points? In my Eclipse client, I am looking at my backlog view of my plan and I have an edit button (new in R2.0 I think), but when I edit the view, the list of attributes does not include story points, or any of my own custom attributes. I'm guessing that story points is not a native attribute, but is part of the scrum template that we're using. So I suppose the question is more general... Can I customize my plan backlog view to include non-native (i.e. custom attributes)?
Thanks,
Alex Feinberg
feinberg@us.ibm.com


Open your Project Area and go to the Process Configuration.

Go to Project Configuration - Configuration Data - Planning - Plan Attributes.

Add the fields to the Attribute Mapping section. I think this should fix it.

permanent link
Michael Scharf (781) | answered Jul 24 '09, 12:19 p.m.
Is there a way to customize the backlog view of my plans to include
the story points? In my Eclipse client, I am looking at my backlog
view of my plan and I have an edit button (new in R2.0 I think), but
when I edit the view, the list of attributes does not include story
points, or any of my own custom attributes. I'm guessing that story
points is not a native attribute, but is part of the scrum template
that we're using. So I suppose the question is more general... Can
I customize my plan backlog view to include non-native (i.e. custom
attributes)?

The story points can indirectly be referenced by the attribute named "Complexity".
You might want to read http://jazz.net/library/article/201 on how to include custom attributes on a plan.

--
MikeS
Jazz Agile Planning team

permanent link
Alex Feinberg (2652) | answered Jul 30 '09, 9:01 a.m.
Thanks for the replies.

I have updated my process configuration so that my "Complexity Attribute" is "Story Points".

I have edited my plan's View Layout to include both "Story Points" and "Complexity", but neither of them actually get displayed in my view.

It seems that there are empty columns for "Story Points" and "Complexity" in my plan view, since I can rearrange the columns and I see things shift, but they columns are empty.

In my "Complexity Attribute" section, the "Attribute" list contains "Story Points" twice, and in my "Attribute Mapping" section is is also listed twice; once with (com.ibm.team.apt.attribute.complexity) and once with just (complexity). I have tried switching my complexity attribute between the two instances, but that didn't help. I'm guessing that it is duplicated as a result of customizations that were made while using RTC 1, but we have since migrated to RTC 2, and the customizations (even the obsolete ones) are lingering around.

Do you have any suggestions for how to sort this out?

Thanks,
Alex

permanent link
Michael Scharf (781) | answered Jul 30 '09, 10:16 a.m.
feinberg wrote:
Thanks for the replies.

I have updated my process configuration so that my "Complexity
Attribute" is "Story Points".

I have edited my plan's View Layout to include both "Story
Points" and "Complexity", but neither of them actually
get displayed in my view.

It seems that there are empty columns for "Story Points" and
"Complexity" in my plan view, since I can rearrange the
columns and I see things shift, but they columns are empty.

In my "Complexity Attribute" section, the
"Attribute" list contains "Story Points" twice,
and in my "Attribute Mapping" section is is also listed
twice; once with (com.ibm.team.apt.attribute.complexity) and once
with just (complexity). I have tried switching my complexity
attribute between the two instances, but that didn't help. I'm
guessing that it is duplicated as a result of customizations that
were made while using RTC 1, but we have since migrated to RTC 2, and
the customizations (even the obsolete ones) are lingering around.

Do you have any suggestions for how to sort this out?

Thanks,
Alex


The columns will remain empty for each work item where no value is associated.

I form your post I assume that you have two custom work item attributes defined: one with the id "complexity", the other with the id "com.ibm.team.apt.attribute.complexity". The latter is the one we ship in new process templates,
but your work items might contain data for the first attribute "complexity".

can you check the process specification source for the following:
1) that your process spec contains only one work item type "Story", and that there's exactly one complexity custom attribute associated (by default with the id "com.ibm.team.apt.attribute.complexity")
2) The "configuration-data" section with the id "com.ibm.team.apt.configuration.attributes" contains one <attribute> element named "Story Points". A <parameter> child element with the key "attribute" should map to "com.ibm.team.apt.attribute.complexity" or the id found in step 1
3) In the same configuration-data section there should be a <complexityAttribute> element with the attributeId parameter set to "com.ibm.team.apt.attributes._com.ibm.team.apt.attribute.complexity" or whatever the value of the "id" attribute of the element in step 2 is
4) if you see more elements related to complexity in this configuration-data section, pls paste the contents here or send it to me for further analysis.

--
MikeS
Jazz Agile Planning team

Your answer


Register or to post your answer.