It's all about the answers!

Ask a question

Error importing Clearcase data into RTC with history.


vinay kumar bondugula (7111845) | asked Sep 26 '15, 12:46 p.m.
edited Sep 26 '15, 12:51 p.m.
 Hi,

I am trying to import Clearcase UCM VOB (version 7.1.1) into RTC 5.0.x with history. But I am experiencing following issues while importing with history. I tried importing without history and it is successful. Please let me know if I am missing anything.

The error while importing with history:

The error below was detected while initializing the Connector algorithm.  The Connector must be properly initialized to function, so further processing is impossible.  Please fix the problem and retry the operation.
CRRTC4061E: The synchronization process cannot be completed. The "cleartool" command completed with a non-zero status or error message:
 
cleartool describe -fmt %[found_bls]CXp stream:DB_Integration@vobuuid:3d84b6e7.69324382.9212.d8:70:99:13:92:d2
baseline:Software_INITIAL@\DB_TEST, baseline:Hardware_INITIAL@\DB_TEST
cleartool: Error: Unable to determine absolute pathname for "3d84b6e7.69324382.9212.d8:70:99:13:92:d2" - No such file or directory
	
	

I Have referred following link:
https://jazz.net/library/article/50
	
	
	
Thank you
	
	
Vinay Kumar
	
	

One answer



permanent link
Geoffrey Clemm (30.0k23035) | answered Sep 26 '15, 1:39 p.m.
FORUM ADMINISTRATOR / FORUM MODERATOR / JAZZ DEVELOPER
edited Sep 26 '15, 1:40 p.m.
Just to confirm, are you running the Baseline importer or the Version Importer?
I'll assume you are running the Baseline importer.

What happens when you execute that cleartool command on the synchronizer host machine (logged on with the same account being used for that synchronization stream).?    Assuming you get the same error, one guess is that the VOB identified by the UUID: 3d84b6e7.69324382.9212.d8:70:99:13:92:d2
is not mounted on the synchronizer host machine. Try mounting it, and try the command again.

Comments
vinay kumar bondugula commented Sep 26 '15, 4:05 p.m. | edited Sep 26 '15, 4:14 p.m.
  1. I am using Cleacase synchronizer for importing clearcase data. I am not aware of version or baseline importer.

    1. I working on the same host where my clearcase server and rtc server are installed and working with Administrator user.

  2. VOB is mounted on the machine i.e. on the clearcase explorer.

    Do I need to lock the VOB, before importing into RTC server?


Geoffrey Clemm commented Sep 26 '15, 4:16 p.m. | edited Sep 26 '15, 4:17 p.m.
FORUM ADMINISTRATOR / FORUM MODERATOR / JAZZ DEVELOPER

If you are using the synchronizer, you are almost surely using the baseline importer.
You do not need to lock the VOB.
You neglected to respond with what happens when you execute the failing cleartool command directly via a command shell on the host machine.


vinay kumar bondugula commented Sep 27 '15, 6:05 a.m.

I recieved the following error while executing the command mentioned in error log:


 cleartool: Error: Unable to determine absolute pathname for "3d84b6e7.69324382.9
212.d8:70:99:13:92:d2" - No such file or directory
baseline:Software_INITIAL@\DB_TEST, baseline:Hardware_INITIAL@\DB_TEST


Geoffrey Clemm commented Sep 27 '15, 4:47 p.m.
FORUM ADMINISTRATOR / FORUM MODERATOR / JAZZ DEVELOPER

It looks like you'll need to work with IBM Support on this one ... in particular, they need to figure out whether this vobuuid is wrong, and if so, where it came from.   They probably will want you to try to create a new synchronization stream, to see if it is just something wrong with this particular synchronization stream.

Your answer


Register or to post your answer.