It's all about the answers!

Ask a question

'Restrict Delivery to Streams' Precondition is not working to restrict delivery of Change Sets


prabhu Rao (115) | asked Sep 10 '15, 5:47 a.m.
Operation: Deliver (server):

'Restrict Delivery to Streams' Precondition is not working to restrict delivery of Change Sets and there are No Specific Configuration Options.
Please help.


Comments
prabhu Rao commented Sep 10 '15, 7:43 a.m.

Need to restrict any changes to the stream after a certain point in time period.
'Restrict Change Set Delivery to Components in a Stream'  precondition is working fine by edit permission to particular user.
Here my question is that can we restrict delivery of changes for particular period using the precondition 'Restrict Delivery to Streams' instead of the above precondition?
If yes, please help me How it will be configured?



prabhu Rao commented Oct 14 '15, 1:56 a.m.

The ‘Restrict Delivery to Streams’ Operation Behavior precondition is working fine in RTC 6.0.1 and not working in RTC 6.0.
We are not able to implement this precondition in RTC 6.0, because there are no specific configuration options to select and add specific streams as shown in the below screen capture.
Is this Operation Behavior precondition ‘Restrict Delivery to Streams’ works in ERTC 6.0?

Accepted answer


permanent link
Susan Wu (4561915) | answered Nov 11 '15, 3:49 p.m.
Restrict Delivery to Streams precondition is a RTC Enterprise Extension feature for restricting promotion only to be delivered to a stream.  If you do not have RTC EE install, you will not see the configure option.  See details from this WI: Add delivery precondition that only allows deliver from promotion (319443)

If you wants to restrict who can deliver changes to a stream, you should use the "Restrict change set delivery to components in a stream" precondition instead.  See details from the following ino center site:

http://www-01.ibm.com/support/knowledgecenter/SSYMRC_6.0.0/com.ibm.team.scm.doc/topics/t_scm_eclipse_restrict_delivery.html?lang=en

Susan
Geoffrey Clemm selected this answer as the correct answer

Your answer


Register or to post your answer.